Bug 2103 - Smbmount still tries to negotiate SMB signing
Smbmount still tries to negotiate SMB signing
Status: RESOLVED DUPLICATE of bug 1920
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
All Linux
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-11-30 11:54 UTC by alexej davidov
Modified: 2014-07-29 13:43 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description alexej davidov 2004-11-30 11:54:54 UTC
Even in Samba 3 the smbmount utility tries to negotiate SMB signing. This will 
not work, as smbfs does not (no longer?) support this. Smbmount will just hang 
after password entry. There is not even some way (at least none that I would be 
aware of) to keep smbmount from using SMB signing.

Thus, if the server is set to signing = mandatory or signing = auto, smbmount 
will fail. As there is no error message on the client side, it is not always 
obvious immediately, why this fails. Only in the server log with a high log 
level one can see, that the client sends a signature with all zeros.

The solution should be to disable SMB signing in smbmount and maybe provide an 
option if one wants to enable it.
Comment 1 Björn Jacke 2014-07-29 13:43:27 UTC

*** This bug has been marked as a duplicate of bug 1920 ***