Bug 2084 - SWAT cannot display parameters with value = "test=this and that"
SWAT cannot display parameters with value = "test=this and that"
Status: RESOLVED DUPLICATE of bug 2137
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.7
All Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 17:21 UTC by Adrian Tam
Modified: 2005-02-17 09:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Tam 2004-11-23 17:21:10 UTC
When I set any parameter that take a string value (such as "passwd 
program", "ldap admin dn") to something that contains spaces and surrounded by 
quotes (e.g. ldap admin dn = "this and that" ), the value will be written to 
the smb.conf file but it will be blank in the SWAT page. Consequently if I set 
some other parameters and commit again, the value of the parameter will be 
removed.

I have seen other bug reports on specific string parameter. But I think this 
is a general problem with how SWAT handles string values with quote and spaces.
Comment 1 Gerald (Jerry) Carter 2005-02-17 09:29:08 UTC

*** This bug has been marked as a duplicate of 2137 ***