Bug 2046 - Printing problem W 98
Printing problem W 98
Status: RESOLVED DUPLICATE of bug 2018
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.8
All Windows 98
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 09:03 UTC by Anderson
Modified: 2004-11-17 10:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anderson 2004-11-17 09:03:59 UTC
The error occurs in stations Windows 98.


[2004/11/17 13:54:44, 1] smbd/service.c:make_connection_snum(648)
  rh (172.19.208.12) connect to service imprh initially as user joao (uid=575, 
gid=501) (pid 6712
)
[2004/11/17 13:54:44, 0] printing/printing_db.c:get_print_db_byname(40)
  PANIC: assert failed at printing/printing_db.c(40)
[2004/11/17 13:54:44, 0] lib/util.c:smb_panic2(1403)
  PANIC: assert failed
[2004/11/17 13:54:44, 0] lib/util.c:smb_panic2(1411)
  BACKTRACE: 16 stack frames:
   #0 smbd(smb_panic2+0x19d) [0x818be31]
   #1 smbd(smb_panic+0x13) [0x818bc8f]
   #2 smbd(get_print_db_byname+0x76) [0x81b1ec6]
   #3 smbd(unpack_pjob+0xf8) [0x81a2564]
   #4 smbd(print_job_set_name+0x23) [0x81a472f]
   #5 smbd(reply_trans+0x5a49) [0x808b609]
   #6 smbd(api_reply+0x2b4) [0x808e238]
   #7 smbd(send_trans_reply+0x90f) [0x8085a6b]
   #8 smbd(reply_trans+0x9ba) [0x808657a]
   #9 smbd(respond_to_all_remaining_local_messages+0x6b4) [0x80bf7d8]
   #10 smbd(respond_to_all_remaining_local_messages+0x74a) [0x80bf86e]
   #11 smbd(process_smb+0x1be) [0x80bfb5e]
   #12 smbd(smbd_process+0x14f) [0x80c062f]
   #13 smbd(main+0x753) [0x81de1df]
   #14 /lib/libc.so.6(__libc_start_main+0xbb) [0x4009b0af]
   #15 smbd(_start+0x21) [0x8073d31]
Comment 1 Guenther Deschner 2004-11-17 10:29:53 UTC
This is already fixed in subversion and will be in 3.0.9.

*** This bug has been marked as a duplicate of 2018 ***