Bug 2018 - PANIC printing from Win98
PANIC printing from Win98
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.8
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
: 2046 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 23:11 UTC by Petr Bravenec
Modified: 2005-08-24 10:16 UTC (History)
1 user (show)

See Also:


Attachments
fix unitialized variable (460 bytes, patch)
2004-11-11 11:01 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Bravenec 2004-11-10 23:11:50 UTC
Samba panic every time i try to print from Win98 & WinME. No problem with
Win2k.Windows say that the printer is not available more (in other language).

[2004/11/11 06:43:36, 3] smbd/lanman.c:api_reply(3574)
  Got API command 147 of form <WWsTP> <WB21BB16B10zWWzDDz>
(tdscnt=49,tpscnt=33,mdrcnt=0,mprcnt=4)
[2004/11/11 06:43:36, 3] smbd/lanman.c:api_reply(3578)
  Doing PrintJobInfo
[2004/11/11 06:43:36, 0] printing/printing_db.c:get_print_db_byname(40)
  PANIC: assert failed at printing/printing_db.c(40)
[2004/11/11 06:43:36, 0] lib/util.c:smb_panic2(1403)
  PANIC: assert failed
[2004/11/11 06:43:36, 0] lib/util.c:smb_panic2(1411)
  BACKTRACE: 16 stack frames:
   #0 smbd(smb_panic2+0x18c) [0x818c38e]
   #1 smbd(smb_panic+0x10) [0x818c200]
   #2 smbd(get_print_db_byname+0x7a) [0x81b16fa]
   #3 smbd [0x81a23bf]
   #4 smbd(print_job_set_name+0x20) [0x81a44ae]
   #5 smbd [0x8089b06]
   #6 smbd(api_reply+0x2b0) [0x808c790]
   #7 smbd [0x808416d]
   #8 smbd(reply_trans+0x959) [0x8084c13]
   #9 smbd [0x80bd81d]
   #10 smbd [0x80bd8a7]
   #11 smbd(process_smb+0x1b9) [0x80bdba5]
   #12 smbd(smbd_process+0x153) [0x80be69b]
   #13 smbd(main+0x715) [0x81daa25]
   #14 /lib/libc.so.6(__libc_start_main+0xa9) [0x400934ed]
   #15 smbd(chroot+0x31) [0x8072b21]
[2004/11/11 06:43:36, 6] param/loadparm.c:lp_file_list_changed(2689)
  lp_file_list_changed()
  file /etc/samba/smb.conf -> /etc/samba/smb.conf  last mod_time: Thu Nov 11
06:40:24 2004
Comment 1 Gerald (Jerry) Carter 2004-11-11 11:01:44 UTC
Created attachment 766 [details]
fix unitialized variable
Comment 2 Gerald (Jerry) Carter 2004-11-11 11:02:05 UTC
patch checked in.
Comment 3 Guenther Deschner 2004-11-17 10:29:55 UTC
*** Bug 2046 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:16:42 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.