Bug 2032 - lines not wrapping in smb.conf manpage
lines not wrapping in smb.conf manpage
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.8
All Linux
: P3 normal
: none
Assigned To: John H Terpstra
Samba Documentation QA Contact~
:
: 1671 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 05:12 UTC by Egmont Koblinger
Modified: 2005-10-17 10:49 UTC (History)
2 users (show)

See Also:


Attachments
bugs in smb.conf.5 (5.73 KB, patch)
2005-09-11 10:37 UTC, Stepan Kasal
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egmont Koblinger 2004-11-13 05:12:45 UTC
man smb.conf looks like this:

[...]

[ around line 260 ]
alias|alias|alias|alias....
           .fi
[ and the next few lines are not wrapped ]

[...]

[ around line 3250 ]
     NET USE Q: \\SERVER\ISO9001_QA.fi
 for example.
[ and lots of subsequent lines are not wrapped ]


The problem is that the ".fi" strings which should terminate the opening ".nf"
are in these cases not at the beginning of a line in the raw manpage file.

While fixing this bug, please check all the other manpages for this case,
I haven't tested them.

I have man 1.5o1 and groff 1.19.1.
Comment 1 Stepan Kasal 2004-11-30 03:50:26 UTC
I can verify that the problem is still present in smb.conf.5 from
samba-docs-latest.tar.bz2 downloaded yesterday.
Comment 2 Stepan Kasal 2004-11-30 03:52:13 UTC
I meant: "I have verified"

The bug has bitten me.  I'm going to search the 3.0.x tarballs for a working
version.
Comment 3 Stepan Kasal 2004-11-30 05:58:34 UTC
Besides the misplaced ".fi" tags, I have also noticed the following bugs in
smb.conf formatting:

The "Example 1" and other examples are misformatted (search for "foo" to see
this).  And they shouldn't be in italics.

The end of unordered list has a bug, which causes wrong indentation.
See the description of the ``addprinter command'' parameter, for example.

Comment 4 Luke Mewburn 2004-11-30 15:10:53 UTC
*** Bug 1671 has been marked as a duplicate of this bug. ***
Comment 5 Gerald (Jerry) Carter 2005-02-01 12:01:23 UTC
updating qa contact
Comment 6 Stepan Kasal 2005-09-11 10:37:23 UTC
Created attachment 1435 [details]
bugs in smb.conf.5

This is a diff against the (generated) file smb.conf.5.  It shows the problems.


The first chunk shows "read only = read only = no", which is probably a dtypo
in the docbook source.	The rest are probably bugs in the convertor, updating
to the latest db2xml is the fist thing to try.	(Sorry, I cannot work on this,
I just wanted to publish my observations.)
Comment 7 Jelmer Vernooij 2005-09-24 04:18:27 UTC
reassigning doc bug to John 
Comment 8 John H Terpstra 2005-10-17 10:49:35 UTC
Fixed.

- John T.