Bug 2031 - Extended error 161 on listing of empty directory from Win98SE (Much more info than Bug 1567)
Extended error 161 on listing of empty directory from Win98SE (Much more info...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
x86 Linux
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 19:45 UTC by Ray Clark
Modified: 2005-08-24 10:22 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ray Clark 2004-11-12 19:45:10 UTC
Samba is 3.04-SUSE that came with SUSE 9.1 Pro, with patches applied from SUSE  
up through mid October 2004.  
  
To reproduce, on Win98SE, J: is samba share, F: is local disk.  
in F:  
mkdir testEmpty  
cd testEmpty  
Make a new file called TEstFile.txt.  This is not known to be important, but it  
makes something in the test directory besides the empty directory.  
mkdir emptyDirectory  
In windows explorer, control-drag testEmpty to J: so as to copy it there.  
  
*I* received the error "System Error 161: The Specified Path is Invalid" from a  
directory hierarchy compare program called Dir Prudence.  
  
You can also see the error by opening a command.com window, changing directory  
to J:\testEmpty\emptyDirectory and doing a "dir".  It lists the . and ..  
entries, then prints "Extended Error 161".  
  
I would *like* to send you a level 9 samba log file, but the bug reporting 
system will not let me because it is too long.  It is just of the command 
prompt failure.  If you mail to webclark at rochester dot rr dot com and copy 
raymond.clark at xerox dot com I will send it to you promptly.  
  
I would appreciate any feedback, especially if it includes a way to make it  
work, or an indication when this might be fixed, or an indication if it will  
not be!  My intent is to migrate to linux, while depending on Win98 when I must  
have an MS platform.  
  
Thank you for your work.  You have indeed made the world a better place,  
because without interoperability with MS we would all be hosed!  
  
Ray Clark  
webclark at rochester dot rr dot com
Comment 1 Jeremy Allison 2004-11-15 13:00:36 UTC
I did some fixes to the pathname parsing between 3.0.4 and 3.0.8. Can you try
this with 3.0.8 and let me know if it fixes the problem ?
Thanks,
Jeremy.
Comment 2 Ray Clark 2004-11-18 17:43:18 UTC
(In reply to comment #1)
> I did some fixes to the pathname parsing between 3.0.4 and 3.0.8. Can you try
> this with 3.0.8 and let me know if it fixes the problem ?

Thanks for the quick response!  I am willing, but have never installed an update
like this.  I am sure I can do it, but a few sentences giving me the big picture
of how to do it and the scope of the task would be a big help.  It will probably
take me a little over a week due to obligations and the thanksgiving holiday. 

Comment 3 Ray Clark 2005-01-22 17:04:57 UTC
(In reply to comment #1)
> I did some fixes to the pathname parsing between 3.0.4 and 3.0.8. Can you try
> this with 3.0.8 and let me know if it fixes the problem ?

Problem still exists, exactly as described, in 3.0.9-2.1-SUSE, which resulted
from an installation of Suse 9.2 followed by patches offered by Suse's online
update.  There was a samba patch.  Changed version of problem to 3.0.9... assume
this was appropriate.

--Ray
Comment 4 Gerald (Jerry) Carter 2005-02-09 09:10:11 UTC
please retest against 3.0.11.  Lots of fixes since 3.0.9.  Thanks.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:22:09 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.