Bug 1567 - Error browsing an empty directory
Error browsing an empty directory
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.5
x86 Windows 98
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 1566 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 01:16 UTC by grawo
Modified: 2006-04-08 22:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grawo 2004-07-28 01:16:33 UTC
Error browsing an empty directory

Two easy steps to achieve this:
1. Make new dir from command prompt on samba share:
   mkdir a
2. Issue dir command:
   dir a

After that you should get a listing of two dotted dirs followed by extended 
error 161. (I don't know the exact message, because the test was done using 
Polish version of Windows 98 SE).
My company (which creates commercial applications) was reported the error by 
two independent users. We had been tracking the error for a week until we came 
to the heart of the matter. 
As far as I know empty directories 'harm' only windows 98 systems, while on 
Windows XP professional 'dir' command works fine (this was not tested but my 
application does work).

I'm looking forward for any info and a fix to this problem (please e-mail me: 
info@symplex.com.pl)

Best regards
Wojciech Gracz
Comment 1 Gerald (Jerry) Carter 2004-08-16 13:49:46 UTC
*** Bug 1566 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2006-04-08 22:33:05 UTC
Please retest against a current release and reopen if the issue still exists.