Bug 1979 - Connection from OS/2 client to Samba 3 server no good
Connection from OS/2 client to Samba 3 server no good
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Linux
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-10-30 11:19 UTC by Thomas Garson
Modified: 2008-06-26 11:48 UTC (History)
3 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Garson 2004-10-30 11:19:31 UTC
This is the same defect as in bug #872 reported last year by Steve Wendt. Since
it is still unresolved, and it results in Samba being unuseable for an OS/2
client, I am adding my $.02:

The behavior is still the case with Samba 3.0.7, both when installed on Suse 9.1
and as delivered in Suse 9.2

I have confirmed correct operation, as configured, of my Samba 3 setup with
Windows 98 as a client.

I am no programmer, but will be happy to provide data or do testing.
Comment 1 Felix Miata 2005-01-02 18:54:26 UTC
I reported my experiences at
Comment 2 Gerald (Jerry) Carter 2005-02-12 07:57:24 UTC
Jim, this might be related to your other OS/2 bug reports.

Also, could the original reporters, please run a quick 
retest against 3.0.11 ?  Thanks.
Comment 3 Gerald (Jerry) Carter 2005-02-18 07:09:10 UTC
update from thomas.....

I have installed binaries for Samba 3.0.11, downloaded 
from samba.org, on my 64-bit Suse Linux 9.2 server. Behavior 
with an OS/2 client is still bad. OS/2 seems to be unable 
to query the server as to what folders and files are preexisting 
in the share. I can copy a file to the share from the OS/2 
workstation, but its icon disappears from the shares folder 
on the OS/2 workstation when the folder is closed and reopened. 
Refreshing the folder brings that files icon back into view. 
At no time can I see files or folders in the share that were 
not copied from the OS/2 workstation.

A Server running Suse 9.0 with Samba 2.2121 on the same 
network works excellently. The later Samba 2.x version (I do 
not have the specific version information at hand) that came 
with Suse 9.1 was my first experience with OS/2 clients 
having problems with Samba such that made it unusable. I had 
hoped that Samba 3 would fix the problems with later versions 
of Samba 2.
Comment 4 Jim McDonough 2005-03-17 07:36:38 UTC
what level of OS/2 are you using?  We have other people using OS/2 successfully
(well, with other errors).
Comment 5 Felix Miata 2005-03-17 11:01:09 UTC
I'm using eCS 1.1 with FP4. Whichever 3.0.x version SuSE 9.2 is using works no
better than that with FC3.

I quit trying to use OS/2 client to connect to samba 3 server. I now use nfs
Comment 6 Thomas Garson 2005-03-17 11:35:26 UTC
(In reply to comment #4)
> what level of OS/2 are you using?  We have other people using OS/2 successfully
> (well, with other errors).

Warp 4.52. I have had successfull operation with Samba up through the release
that came with Suse 9.0, samba 2.2.12-1 SUSE. All releases I have tried after
that have been NG with OS/2.

Until that time, I was able to see periodic incremental improvements in OS/2
interoperability with samba. Then blooey.

I'm told that it has something to do with a patch to samba that was made to
accomodate a change in Windows. Unfortunately, that patch was brought into the
main code steam without broad testing, probably in a hurry, by necessity. 
It's really sad that we have to dance with a partner who steps on our feet on
Comment 7 Jeremy Allison 2005-03-17 11:45:52 UTC
We're trying hard to fix up OS/2 support in 3.0.12 and above. Please
keep bugging us about things that don't work. We don't have a good OS/2
test environment as it doesn't run on vmware. If you can find a virtual
machine that can host OS/2 clients we will add it to our testing schedule.

Please keep giving us feedback - we *will* fix these bugs.

Comment 8 Felix Miata 2005-03-17 12:39:51 UTC
Most of my machines are configured for multiboot. It isn't that hard. Install
OS/2 or eComStation as intended, directly to its own partition.
Comment 9 thomas schönemann 2005-04-28 09:31:30 UTC
i now installed samba3.0.15 on either our sun solaris9 host (ufs filesystem
without ea support) as on a gentoo-linux-system with reiserfs and user_xattrs

on both environments i see the EA problem as follows:

1)  "ea enabled = yes" 
-i can see,open,delete all files/folders via os/2 commandline and via WPS.
-if i copy files via command-line (file without EAs) it works.
-if i copy files via command-line (file with EAs) i get "access denied" BUT the
file is created with zero-size (without eas). Copying again succeeds (because
the file already exists)
-if i copy via WPS (file without EAs) i get "sys0266 file not copied" - but the
file is created with null-size as above
-if i copy via WPA (file with EAs) i get "extended attributes not supported ..."
and then "sys0266 file not copied"

2) ea enabled = no
things are quite more strange with the WPS:
-everything via command-line works well (ok - no EAs) 
-the WPS behaves strange, no error messages (except for files with EA "extended
attributes are not supported...") , i can copy files to and back the samba
folder - but the folder view stores its information somewhere in nirvana:
if i delete icons - they remain as do the files. If i copy or delete something
via commandline - the folder-view does NOT recognize that.
Reopening the folder does not change anything
Comment 10 thomas schönemann 2005-04-28 09:37:19 UTC
i will attach to this bug 8 files (smbd.log, debuglevel 10)

for all 8 copy-file operations i mentioned above:

4 x with "ea support = on" in smb.conf
  1 x commandline copy a file with EA
  1 x commandline copy a file without EA
  1 x WPS copy a file with EA
  1 x WPS copy a file without EA

4 x with "ea support = off" in smb.conf
  1 x commandline copy a file with EA
  1 x commandline copy a file without EA
  1 x WPS copy a file with EA
  1 x WPS copy a file without EA

filenames should be ok ;-)))

Comment 11 thomas schönemann 2005-04-28 09:51:51 UTC
sorry - 
i attached my 8 smbd.log files for the EA on copying actions
to bug 2661.

I dont know how to delete them there or to move them here...

but i think ist the same problem - 
so one of the bugs could be marked as duplicate of the other.

Comment 12 Thomas Garson 2005-05-20 11:44:08 UTC

Warp 4.52 with XRC004 installed, connecting to Suse 9.2 (AMD64) with Samba

EA support is enabled in Samba configuration on server


Operations performed from OS2 workplace shell:

OS2 displays the following message before allowing an object to be copied to the
"File properties (extended attributes) cannot be copied to the destination file
system. Are you sure you want to copy Brevete horn?"
After selecting "Yes", the directory and the four files in it are successfully

Message from OS2 after failure of attempt to copy a directory (called "SPEDE")
with files and a sub directory with files to Samba share:
"The parameter is incorrect"
Second attempt attemt to copy the same directory triggers this message from OS/2:
" An error has occurred and the message is not accessable. Contact the supplier
of the application."

I get no errors If I drag an empty folder to the share and then copy all files
and the single sub directory from the directory SPEDE to that folder.


Operations performed from an OS/2 windowed command line session:

Xcopy /s stalls while copying a directory with files and folders to the share.
When this happens OS/2 has lost its connection to the share. The window freezes
and can't be closed. An OS/2 reboot is required to restore operation and C-A-D
is blocked. A hardware reset is required.
If I don't try to copy the folders in the directory (no /s), XCopy is
successfull copying all files.


It would seem that there is a serious problem creating folders during any copy
operations to a Samba share.
OS/2s ability to recover from failure of the connection to a Samba share is now
singularly catastrophic.
Excessively strange, even for OS/2 ;-(


Although Samba 3 is still not useable with OS/2. there seems to be some progress
here. My thanks to those working on it.
Comment 13 Thomas Garson 2006-02-08 03:49:31 UTC
Update for Samba 3.021b (64 bit) installled on same system (Suse 9.2/AMD Athlon 64):

Hey team, youre getting closer!

EAs seem to be working now as atributes (via right click) of a file copied to a Samba share from my OS/2 box show up the same as for a local drive. Xcopy from the Samba share to a local drive works peachy. I can use "Filestar" to move files and directories back and forth between shared and local drives with no observed problems. Xcopy can now create directories and sub folders on a Samba share.

Now for what still needs work;-(
1) Xcopy from a local drive to a Samba share terminates early, most often with the message "SYS1189: XCopy cannot close the source or target file". Usually this happens after copying somewhere in the neighorhood of 2500 out of the 5200 files in my test directory structure.

2) Drag and drop of my test directory (many files plus several sub directories with numerous files) results in the creation of the directory folder with no contents and, much worse, a C-A-D level hang of the OS/2 desktop.

3) A new wrinkle is drag and drop also does not work properly (terminates early) from the same Samba share to a local drive on my Windows 2000 machine and xcopy from the same share to the same local drive is very very slow and terminates early.

I'll be happy to try and provide any more specific information that may be needed.

Comment 14 Jeremy Allison 2006-02-08 11:09:13 UTC
Can you get me ethereal traces and debug level 10 log files for (1), (2), and (3) please. I know theres an outstanding bug with receiving trans2 packets out of order, but we are planning to fix this sometime in the future (lots of other things to do first though :-). The more info we have the better this will get.
Thanks a lot for all your testing work !
Comment 15 Gerald (Jerry) Carter 2006-04-08 07:43:40 UTC
Cleaning up versions.  There was no 3.0.15 so leaving it in bugzilla 
is causing some confusion.  Moving these nuder 3.0.20.
Originally files against 3.0.15preX.
Comment 16 Gerald (Jerry) Carter 2006-04-20 08:03:31 UTC
severity should be determined by the developers and not the reporter.
Comment 17 Jim McDonough 2008-06-26 11:31:49 UTC
Still not working?  See previous comment about posting info, and if it's still not working, please reopen and post the requested traces.