Bug 872 - opening folders from OS/2 client failures
opening folders from OS/2 client failures
Status: VERIFIED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.0
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 17:35 UTC by Steve Wendt
Modified: 2005-04-28 07:41 UTC (History)
4 users (show)

See Also:


Attachments
tcpdump from Linux machine for OS/2 client (14.33 KB, text/plain)
2003-12-09 17:37 UTC, Steve Wendt
no flags Details
result of "tcpdump -s 0 -w tcpdump.log host <ip>" (13.26 KB, text/plain)
2005-03-24 16:47 UTC, Steve Wendt
no flags Details
modified trans2.c (136.18 KB, text/plain)
2005-04-04 07:51 UTC, thomas schönemann
no flags Details
zip of level 10 debug log (14.06 KB, application/zip)
2005-04-27 13:38 UTC, Steve Wendt
no flags Details
zip of level 10 debug log (26.26 KB, application/zip)
2005-04-27 14:22 UTC, Steve Wendt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wendt 2003-12-09 17:35:01 UTC
Running Samba server 3.0.0 and/or 3.0.1rc1 on Red Hat 8.0.  Seems to work well
with Windows XP clients (haven't tested earlier Windows versions much yet), but
has lots of problems with OS/2 clients.

I can use "net use" to map a drive letter to a Samba share, but when trying to
open the share (or drive letter) from the WPS, it gives me error messages, and
nothing is displayed.

Using the OS/2 SMB Tracing Tool, we see things like this:
Understands long file names, Errors in NT status format,
Unknown secondary SMB flags: 0x18433

I have tried "nt status support = no" but it didn't change anything.  The
protocol negotiation seems to come up with LM1.2X002, which I suppose is what
Samba calls LANMAN2.
Comment 1 Steve Wendt 2003-12-09 17:36:21 UTC
By the way, the "error messages" are pretty useless:  "No objects were found"
and "The system call level is incorrect"

Comment 2 Steve Wendt 2003-12-09 17:37:10 UTC
Created attachment 312 [details]
tcpdump from Linux machine for OS/2 client
Comment 3 Gerald (Jerry) Carter 2005-02-08 21:41:32 UTC
please retest 3.0.11 and reopen if necessary.
Comment 4 Steve Wendt 2005-02-09 16:05:00 UTC
No change in 3.0.11.
Comment 5 Jeremy Allison 2005-03-17 11:46:16 UTC
The supplied tcpdump has truncated frames. Please redo this with the option to
save *all* the frame contents. Thanks,

Jeremy.
Comment 6 Steve Wendt 2005-03-24 16:47:05 UTC
Created attachment 1114 [details]
result of "tcpdump -s 0 -w tcpdump.log host <ip>"

This is with Samba 3.0.13.  If my tcpdump options are not adequate, please let
me know what I should use instead.
Comment 7 thomas schönemann 2005-04-04 07:48:25 UTC
(In reply to comment #0)
> 
> ....
>
> I can use "net use" to map a drive letter to a Samba share, but when trying to
> open the share (or drive letter) from the WPS, it gives me error messages, and
> nothing is displayed.
> 
> By the way, the "error messages" are pretty useless:  "No objects were found"
> and "The system call level is incorrect

hello steve, jeremy

this bug is a dupe of #1677!

the problem is, that some code in TRANS2.C necessary for the EA 
(extended Atrribute) handling got lost in samba3. 
Because of incorrect EA handling in samba the OS/2 WPS (working with EA) is
unsatisfied and reports "no object were found" - while the os/2 command line 
(not working with EA) works good.

I made samba3 working with os/2 with some "dirty hacks" in trans2.c.
I really didnt understand too much of trans2.c but i compared with
samba2 and discovered that info_levels SMB_INFO_QUERY_EAS_FROM_LIST and
SMB_INFO_QUERY_ALL_EAS got lost.  (see bug #1677 and frank giesslers comments)

So at three points in the source i added the missing lines and samba works for me.


i try to attach my trans2.c - you can easily find my changes because of the 
DIRTY_EA_FIX_THOMAS define.

Perhaps someone with more skills in trans2.c can make the code really right!

thomas
Comment 8 thomas schönemann 2005-04-04 07:51:02 UTC
Created attachment 1136 [details]
modified trans2.c 


see reply above
Comment 9 Steve Wendt 2005-04-04 10:13:46 UTC
Thanks, Thomas!

*** This bug has been marked as a duplicate of 1677 ***
Comment 10 Felix Miata 2005-04-04 10:27:00 UTC
Since this came first, the other is a dupe of this. Plus, this one has a summary
someone searching the bug database could logically find. The other summary is
just so much gibberish to me.
Comment 11 Steve Wendt 2005-04-19 16:31:02 UTC
Testing with Samba 3.0.15pre2, I get the same "No objects were found" dialog,
followed by "SYS0282: The target file system cannot save extended attributes."
Comment 12 Jeremy Allison 2005-04-19 19:05:15 UTC
Send me a debug level 10 log showing smbd attempting to save the EA. If you're
not running on a filesystem that supports EA's then you will get this message
even though the bug is fixed.
Jeremy.
Comment 13 Steve Wendt 2005-04-20 10:45:40 UTC
(In reply to comment #12)
> If you're not running on a filesystem that supports EA's then you will get this 
> message even though the bug is fixed.

That's probably the case, sorry for the bug spam.  I'll test on another (newer)
system, and report back.
Comment 14 Steve Wendt 2005-04-27 13:37:46 UTC
Tested 3.0.15pre2 on a FC3 system, using ext3 with ext_attr attribute enabled.

Copying a file with an EA (os2krnl) via command line does not produce an error
message, but no EA is created either.

Opening the drive folder, produces the "No objects were found" message the first
time, and creates the "WP ROOT . SF" file, although it doesn't hide it.  Opening
the drive folder the second time, it produces the "No objects were found"
message AND "SYS0282: The target file system cannot save extended attributes."
Comment 15 Steve Wendt 2005-04-27 13:38:08 UTC
Created attachment 1182 [details]
zip of level 10 debug log
Comment 16 Jeremy Allison 2005-04-27 13:45:53 UTC
You need to tell Samba that the filesystem supports EA's.
Do you have :

ea support = yes

set in the global section of your smb.conf ?

Jeremy.
Comment 17 Steve Wendt 2005-04-27 14:22:21 UTC
Created attachment 1183 [details]
zip of level 10 debug log

Doh!  Looks like I missed that new parameter, added way back in 3.0.3.	That
fixes the subject bug, although copying files from command line is back to
producing the "target file system does not support them" message.  It looks
like *everything* has EAs now, although it is all SELinux stuff, not OS/2 EAs.
Comment 18 Steve Wendt 2005-04-27 14:24:10 UTC
Should I close this bug, and open a new one for remaining problem?
Comment 19 Jeremy Allison 2005-04-27 15:21:01 UTC
Yes, please log a new bug.
Jeremy.
Comment 20 Steve Wendt 2005-04-27 15:50:59 UTC
Opened bug 2661.
Comment 21 Felix Miata 2005-04-28 07:41:30 UTC
I rebuilt 4 days ago, and it still fails for me. I wish I could get something
other than simple DIR listings to work. I can't get OS/2 to use samba shares,
nor can I get Linux to use OS/2 shares. I've been told I can no longer use smbfs
in fstab, but must mount with CIFS, which OS/2 does not support.