Bug 1908 - swat changes passdb backend value
swat changes passdb backend value
Status: RESOLVED DUPLICATE of bug 2137
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.7
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 05:06 UTC by Dirk Kastens
Modified: 2005-02-17 10:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Kastens 2004-10-11 05:06:32 UTC
I configured two LDAP servers with the passdb backend attribute:

passdb backend = "ldapsam:ldap://ldap1.server ldap://ldap2.server"

Whenever I use SWAT to change some configuration, the entry in
the samba.conf file changes to:

passdb backend = 'ldapsam:ldap://ldap1.server, ldap://ldap2.server'

The comma makes the entry to not work any longer, what means that
no user can be authenticated against LDAP.
Comment 1 Gerald (Jerry) Carter 2004-10-11 05:51:40 UTC
single quotes are the only valid smb.conf grouping tokens 
in current versions os Samba.
Comment 2 Dirk Kastens 2004-10-11 07:27:29 UTC
Maybe, but the LDAP authentication with two LDAP servers only works if I put the
following line into smb.conf, including the double quotes:

passdb backend = "ldapsam:ldap://ldap1.server ldap://ldap2.server"

And the Samba help file says: "Multiple servers may also be specified in
double-quotes,..."
When I use SWAT, the program ALWAYS puts a comma between the two server names
and exchanges the double quotes with single quotes. The LDAP authentication DOES
NOT work afterwards. Using single quotes, the error message in log.smbd is:

[2004/10/11 16:23:49, 0] passdb/pdb_interface.c:make_pdb_methods_name(664)
  No builtin nor plugin backend for 'ldapsam found
[2004/10/11 16:23:49, 1] passdb/pdb_interface.c:make_pdb_context_list(765)
  Loading 'ldapsam:ldap://ldap1.server failed!

I tried all possible combinations of single quotes, double quotes, with, and
without a comma. The above example is the only one that works.
So each time after I used SWAT to change the configuration, I have to edit the
smb.conf file by hand and change the passdb backend entry to the example above.
Comment 3 Tomas Tamm 2004-11-30 09:47:06 UTC
I have the same problem. I read somewhere in the doku that there are two 
different meanings when using passdb backend with and without comma.

    ldapsam:"ldap://server1 ldap://server2"

means two ldap-server working as failover to eachother whereas

    ldapsam:ldap://server1, ldapsam:ldap://server2 (yes, this works)

means that the passdb-database is divided in two pars that reside on different 
server. 

It seems that swat always assumes the second syntax and inserts a comma.
Comment 4 Dirk Kastens 2004-12-01 01:23:15 UTC
Good to hear that I'm not the only one :-)
Unfortunately, the bug still exists in samba 3.0.8 :-(
Comment 5 Gerald (Jerry) Carter 2005-02-17 10:27:31 UTC

*** This bug has been marked as a duplicate of 2137 ***