Bug 1833 - dirent64_convert compile problems with smbwrapper/smbw.po
dirent64_convert compile problems with smbwrapper/smbw.po
Status: RESOLVED DUPLICATE of bug 1776
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.7
All Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-26 12:33 UTC by René Laederach
Modified: 2004-10-09 08:05 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Laederach 2004-09-26 12:33:35 UTC
I've successfully compiled Samba 3.0.6 on a variety of boxes with the following
./configure options:

./configure --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --libdir=/etc/samba --with-fhs
--with-privatedir=/etc/samba/private --with-lockdir=/var/cache/samba
--with-swatdir=/usr/share/swat --with-automount --with-smbmount --with-pam
--with-mmap --with-quotas --with-libsmbclient --with-utmp
--with-piddir=/var/run/samba --with-acl-support --with-vfs --with-msdfs
--with-winbind --with-ldap --enable-cups --with-quotas
--with-logfilebase=/var/log --with-smbwrapper

====================================================================

I already successfully compiled samba up to version 3.0.6 with these settings,
so this works. However this:

===================================================================


Compiling smbwrapper/smbw.c with -fPIC
smbwrapper/smbw.c: In function `smbw_init':
smbwrapper/smbw.c:63: warning: assignment from incompatible pointer type
smbwrapper/smbw.c: In function `smbw_find_workgroup':
smbwrapper/smbw.c:262: warning: assignment discards qualifiers from pointer
target type
smbwrapper/smbw.c:268: warning: passing arg 3 of `name_resolve_bcast' from
incompatible pointer type
smbwrapper/smbw.c: In function `smbw_parse_path':
smbwrapper/smbw.c:323: warning: passing arg 1 of `next_token' from incompatible
pointer type
smbwrapper/smbw.c:331: warning: passing arg 1 of `next_token' from incompatible
pointer type
smbwrapper/smbw.c:338: warning: passing arg 1 of `next_token' from incompatible
pointer type
smbwrapper/smbw.c: In function `get_envvar_auth_data':
smbwrapper/smbw.c:413: warning: assignment discards qualifiers from pointer
target type
smbwrapper/smbw.c: In function `smbw_lseek':
smbwrapper/smbw.c:1250: warning: passing arg 4 of `cli_getattrE' from
incompatible pointer type
Compiling smbwrapper/smbw_dir.c with -fPIC
Compiling smbwrapper/smbw_stat.c with -fPIC
smbwrapper/smbw_stat.c: In function `smbw_fstat':
smbwrapper/smbw_stat.c:151: warning: passing arg 4 of `cli_getattrE' from
incompatible pointer type
Compiling smbwrapper/realcalls.c with -fPIC
Compiling smbwrapper/shared.c with -fPIC
Compiling smbwrapper/smbw_cache.c with -fPIC
Compiling smbwrapper/wrapped.c with -fPIC
Linking shared library bin/smbwrapper.so
smbwrapper/smbw.po: In function `dirent64_convert':
smbwrapper/smbw.po(.text+0x2f30): undefined reference to
`__unsafe_string_function_usage_here__'
smbwrapper/wrapped.po: In function `pread':
smbwrapper/wrapped.po(.text+0x10c): undefined reference to `real_pread'
smbwrapper/wrapped.po: In function `pwrite':
smbwrapper/wrapped.po(.text+0x1c0): undefined reference to `real_pwrite'
smbwrapper/wrapped.po: In function `stat64':
smbwrapper/wrapped.po(.text+0xbb2): undefined reference to `real_stat64'
smbwrapper/wrapped.po: In function `fstat64':
smbwrapper/wrapped.po(.text+0xc10): undefined reference to `real_fstat64'
smbwrapper/wrapped.po: In function `lstat64':
smbwrapper/wrapped.po(.text+0xc6e): undefined reference to `real_lstat64'
smbwrapper/wrapped.po: In function `llseek':
smbwrapper/wrapped.po(.text+0xcbc): undefined reference to `real_llseek'
smbwrapper/wrapped.po: In function `readdir64':
smbwrapper/wrapped.po(.text+0xd1e): undefined reference to `real_readdir64'

=======================================================

creates the above error message. Anybody got a fix? I have the same problems on
samba 3.1 HEAD.
Comment 1 René Laederach 2004-10-09 08:05:17 UTC
See patch in bug 1832

*** This bug has been marked as a duplicate of 1776 ***