Bug 1832 - Problems building plugin modules/CP437.so and CP850.so
Problems building plugin modules/CP437.so and CP850.so
Status: RESOLVED DUPLICATE of bug 1776
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.7
x86 Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-26 12:26 UTC by René Laederach
Modified: 2004-10-09 08:04 UTC (History)
0 users

See Also:


Attachments
This patch from michel.gravey!7ici.biz.invalid fixed it (1.09 KB, patch)
2004-10-09 08:03 UTC, René Laederach
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description René Laederach 2004-09-26 12:26:49 UTC
I've successfully compiled Samba 3.0.6 on a variety of boxes with the following
./configure options:

./configure --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --libdir=/etc/samba --with-fhs
--with-privatedir=/etc/samba/private --with-lockdir=/var/cache/samba
--with-swatdir=/usr/share/swat --with-automount --with-smbmount --with-pam
--with-mmap --with-quotas --with-libsmbclient --with-utmp
--with-piddir=/var/run/samba --with-acl-support --with-vfs --with-msdfs
--with-winbind --with-ldap --enable-cups --with-quotas --with-logfilebase=/var/log

===============

So far, this worked well, and gave me working executables on a variety of RH8
and RH9 machines with self-built 2.4.27 kernels. However, with 3.0.7 and 3.1.0,
I always get this error. From my research, it seems that this bug is known. Is
there a workaround or a patch? To me it seems some build config that doesn't
work as advertised.

On an RH8 machine without --with-smbwrapper option, I get this:

Compiling modules/CP850.c with -fPIC
Building plugin bin/CP850.so
modules/CP850.po: In function `init_module':
modules/CP850.po(.text+0x184): undefined reference to `smb_register_charset'
Compiling modules/CP437.c with -fPIC
Building plugin bin/CP437.so
modules/CP437.po: In function `init_module':
modules/CP437.po(.text+0x184): undefined reference to `smb_register_charset'


================================================

glibc version is 2.3.2-4.80.8 on the machine where the compile failed.
Comment 1 René Laederach 2004-10-09 08:03:47 UTC
Created attachment 711 [details]
This patch from michel.gravey!7ici.biz.invalid fixed it
Comment 2 René Laederach 2004-10-09 08:04:43 UTC

*** This bug has been marked as a duplicate of 1776 ***