Bug 1789 - Smbmount failure against win2003srv ADC
Smbmount failure against win2003srv ADC
Status: RESOLVED DUPLICATE of bug 1920
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.7
x86 Linux
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 10:07 UTC by Roberto Colmegna
Modified: 2004-10-19 15:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Colmegna 2004-09-17 10:07:05 UTC
Launching smbmount command against win2003 shared folders
you can obtain a failure as show below.
But if you launch:
smbclient "//SERVER/TEST" xyz -U Administrator 
it works correctly and shows samba prompt.

Using "client use spnego = yes" in smb.conf doesn't solve
the problem. 

SysInfo:
Samba: Version 3.0.7-1

Linux: (Rad Hat 9.0) 2.4.20-8 #1 Thu Mar 13 17:18:24 EST 2003 i686 athlon i386
GNU/Linux


-------------------  smbmount dump ---------------
[root@linux-rm root]# smbmount "//SERVER/TEST" /mnt/win -o
username=Administrator,password=xyz,debug=4
mount.smbfs started (version 3.0.7)
added interface ip=192.168.60.3 bcast=192.168.60.255 nmask=255.255.255.0
added interface ip=192.168.60.4 bcast=192.168.60.255 nmask=255.255.255.0
Connecting to 192.168.60.5 at port 445
5624: session request ok
Serverzone is -7200
cli_negprot: SMB signing is mandatory and we have disabled it.
5624: protocol negotiation failed
SMB connection failed
[root@linux-rm root]#
Comment 1 Björn Jacke 2004-10-19 15:42:22 UTC
the log says it all:

cli_negprot: SMB signing is mandatory and we have disabled it.

smbfs does not support smb signing ...

*** This bug has been marked as a duplicate of 1920 ***