Bug 1629 - smbclient can not display shared directory whose name more than 13 char
smbclient can not display shared directory whose name more than 13 char
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.6
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 2188 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 20:05 UTC by shufeng yang
Modified: 2005-03-22 14:52 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shufeng yang 2004-08-18 20:05:48 UTC
when a host A share a directory whose name more than 13 chars,
In host B, user the command "smbclient -L A", it can only display the first 13
chars of the share name in host A
Comment 1 Matt Seitz 2004-11-18 11:35:12 UTC
As a workaround, you can display all the share names by using the Samba "net rpc
share" command.  See:

http://samba.org/samba/docs/man/net.8.html
Comment 2 Matt Seitz 2004-11-18 14:58:41 UTC
Actually, "net rpc share" is only a partial workaround.  It will list the longer
share names, but it will truncate the names at 12 characters.
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:40:49 UTC
originally against 3.0.6rc2
Comment 4 Jelmer Vernooij 2005-03-15 09:22:04 UTC
*** Bug 2188 has been marked as a duplicate of this bug. ***
Comment 5 Gerald (Jerry) Carter 2005-03-22 14:52:29 UTC
the current behavior is not an issue in smbclient, but in smbd
where it will not enumerate shares >= 13 characters in length 
via the NetShareEnum rap call.  This is actually correct behavior.