Bug 1587 - Webtrends blows samba drive mapping up
Webtrends blows samba drive mapping up
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.7
x86 Windows 2000
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 08:57 UTC by Bill Chmura
Modified: 2005-08-24 10:23 UTC (History)
1 user (show)

See Also:


Attachments
Capture of traffic when the problem occurs (11.06 KB, application/octet-stream)
2004-09-22 13:39 UTC, Bill Chmura
no flags Details
Log files from the event set to debug 10 (16.20 KB, application/gzip)
2004-09-22 13:44 UTC, Bill Chmura
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Chmura 2004-08-05 08:57:13 UTC
This problem is so similar to that fixed in bug #1345, but I am running 3.0.4
with the patch for that bug and the problem persists.  Basically this is new
under the 3.x series - 2.x was on the server before this and it was not a
problem.  I can map to the samba server from the windows box and do all kinds of
stuff (read, write, create, make new directories, open with Word, Excel...). 
When I run webtrends against a file on the shared drive the drive mapping
disconnects and web trends claims it cant get at the file.  Inside webtrends I
can use the standard windows browse to a file dialog to access the info, its
just when it runs.  Not sure if its doing something strange to access the files.  

I checked the log files and there is nothing strange in the samba end. 
Disturbingly little.  Please advise what I should do next to provide information
on this.  Its probably not affecting a lot of people, but we've had our reports
off line for a month so far trying to resolve it!  Help!
Comment 1 Gerald (Jerry) Carter 2004-08-16 14:01:47 UTC
could you test 3.0.6rc2 please ?
Comment 2 Bill Chmura 2004-08-16 17:24:19 UTC
I will be able to do this over the next few days... I will advise as soon as I
get it installed and tested!

Thanks
Comment 3 Bill Chmura 2004-09-20 21:57:34 UTC
I was finally able to get the samba server upgraded and I am still having the
problem.  I have jumped right to Samba 3.0.7 and the problem is unchanged.  I am
not sure what to report from what file.

Please let me know what to do and I will send whatever debug info you want!
Comment 4 Jeremy Allison 2004-09-21 17:44:27 UTC
I need a debug level 10, and an ethereal capture trace, between
the client trying to access the server. The error message from the
client app would also help a lot.

Can you tell me how to reproduce this ? Is there a demo version of
this app I can download and try ?

Thanks.

Jeremy.
Comment 5 Bill Chmura 2004-09-22 12:05:07 UTC
I changed the version above to reflect 3.0.7.  This post will contain the
application end of the problem. The next will have the debug 10 log and an
ethereal capture.

The Application is WebTrends Professional Suite 5.0.  I do not think there is an
evaluation version for download.  There is a version: Webtrends 7.0 which is
available for a demo.  To upgrade to this would cost us $3000 and I don't have
it to spend right now.

When I run the application, I can browse to the files location on the samba
server just fine.  I can also, from any other application I have tried access,
modify and change files (the same file I am trying to process).

When I actually try to run a report (when it opens the file up) I get a message
almost immediately saying 

"Could not open the log file G:\clients\eastern\access-logs\access-log  Please
check the spelling and make sure the file exists."

The windows filemanager will now show the drive as disconnected until I click on
it again.

I should stress that the file does exist, is readable and writeable and was
previously working.  It also occurs on all of the different reports.

I will try to get the debug and stuff now...

Thanks for your help!




Comment 6 Bill Chmura 2004-09-22 13:39:31 UTC
Created attachment 675 [details]
Capture of traffic when the problem occurs

This log shows me clicking on the share in explorer to bring it up, then the
next thing is running the report and getting the error.
Comment 7 Bill Chmura 2004-09-22 13:44:54 UTC
Created attachment 676 [details]
Log files from the event set to debug 10

All the log files that I think could be relevant.  I cleared them just before
recreating the problem.
Comment 8 Bill Chmura 2004-09-22 13:47:45 UTC
I added in the ethereal capture (I had no idea that would show that much!) and
the debug logs.  The ethereal capture shows that it is trying to reconnect and
failing (as far as I can tell).  The application goes after a drive mapping (in
this case G:).  The same way I browse normally.

Let me know what else I can provide or try!

Comment 9 Gerald (Jerry) Carter 2005-02-09 08:58:14 UTC
please retest against 3.0.11 and reopen if necessary.  Thanks.
Comment 10 Gerald (Jerry) Carter 2005-08-24 10:23:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.