Bug 1345 - Macromedia Homesite cannot connect anymore after upgrade to 3.0.4
Macromedia Homesite cannot connect anymore after upgrade to 3.0.4
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.4
All Windows XP
: P3 normal
: none
Assigned To: Jeremy Allison
:
: 1354 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 04:20 UTC by Dick Visser
Modified: 2005-08-24 10:16 UTC (History)
3 users (show)

See Also:


Attachments
Patch for macromedia bug. (385 bytes, patch)
2004-05-13 18:19 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dick Visser 2004-05-12 04:20:19 UTC
I use the samba provided binaries for Debian, and after upgrading from 3.0.2 to
3.0.4 I cannot connect to my servers anymore with Macromedia Homesite (5.0 + 5.5).
This is very strange because I can reach the shares with the Windows Explorer
just fine.
I suspect Homesite does not use the Windows API for accessing network shares but
has some creepy custom code to do this.
FYI if I try to access a share with Homesite, my log says this:

[2004/05/12 13:16:52, 3] smbd/process.c:process_smb(890)
  Transaction 874 of length 92
[2004/05/12 13:16:52, 3] smbd/process.c:switch_message(685)
  switch message SMBntcreateX (pid 19688)
[2004/05/12 13:16:52, 4] smbd/uid.c:change_to_user(186)
  change_to_user: Skipping user change - already user
[2004/05/12 13:16:52, 3] smbd/open.c:open_directory(1356)
  open_directory: unable to stat name = .. Error was Success
[2004/05/12 13:16:52, 3] smbd/error.c:error_packet(118)
  error packet at smbd/trans2.c(2222) cmd=162 (SMBntcreateX) NT_STATUS_ACCESS_DENIED
[2004/05/12 13:16:52, 3] smbd/process.c:process_smb(890)
  Transaction 875 of length 92
[2004/05/12 13:16:52, 3] smbd/process.c:switch_message(685)
  switch message SMBntcreateX (pid 19688)
[2004/05/12 13:16:52, 4] smbd/uid.c:change_to_user(186)
  change_to_user: Skipping user change - already user
[2004/05/12 13:16:52, 3] smbd/dosmode.c:unix_mode(111)
  unix_mode(.) returning 0764
[2004/05/12 13:16:52, 4] smbd/open.c:open_file_shared1(1010)
  calling open_file with flags=0x0 flags2=0x0 mode=0764
[2004/05/12 13:16:52, 3] smbd/process.c:process_smb(890)
  Transaction 876 of length 76
[2004/05/12 13:16:52, 3] smbd/process.c:switch_message(685)
  switch message SMBtrans2 (pid 19688)
[2004/05/12 13:16:52, 4] smbd/uid.c:change_to_user(186)
  change_to_user: Skipping user change - already user
[2004/05/12 13:16:52, 3] smbd/trans2.c:call_trans2qfilepathinfo(2268)
  call_trans2qfilepathinfo: TRANSACT2_QFILEINFO: level = 1004
[2004/05/12 13:16:52, 3] smbd/trans2.c:call_trans2qfilepathinfo(2362)
  call_trans2qfilepathinfo . (fnum = 7654) level=1004 call=7 total_data=0
[2004/05/12 13:16:52, 3] smbd/process.c:process_smb(890)
  Transaction 877 of length 45
[2004/05/12 13:16:52, 3] smbd/process.c:switch_message(685)
  switch message SMBclose (pid 19688)
[2004/05/12 13:16:52, 4] smbd/uid.c:change_to_user(186)
  change_to_user: Skipping user change - already user
[2004/05/12 13:16:52, 3] smbd/reply.c:reply_close(2679)
  close directory fnum=7654
[2004/05/12 13:16:52, 3] smbd/process.c:process_smb(890)
  Transaction 878 of length 92
[2004/05/12 13:16:52, 3] smbd/process.c:switch_message(685)
  switch message SMBntcreateX (pid 19688)
[2004/05/12 13:16:52, 4] smbd/uid.c:change_to_user(186)
  change_to_user: Skipping user change - already user
[2004/05/12 13:16:52, 3] smbd/open.c:open_directory(1356)
  open_directory: unable to stat name = .. Error was Success
[2004/05/12 13:16:52, 3] smbd/error.c:error_packet(118)
  error packet at smbd/trans2.c(2222) cmd=162 (SMBntcreateX) NT_STATUS_ACCESS_DENIED

Any help would be appreciated.
My employees cannot work anymore.
I will try to get the older binaries back.
Comment 1 Gerald (Jerry) Carter 2004-05-12 08:19:24 UTC
Jeremy, please look at this one.
Comment 2 Bartolomeo D'Alia 2004-05-12 12:48:26 UTC
I have the same problem no windows 2000, after upgrade homesite is not able to
open network drives. 
I have verified that this problem not happen on windows 98 and windows me.
Comment 3 Jeremy Allison 2004-05-13 17:41:30 UTC
This is getting caught by the new check_path_syntax() code that
catches invalid paths such as "..".
What would help here is a ethereal capture file showing it failing against
Samba 3.0.4 and a ethereal capture file showing it succeeding against WNT/2k/2k3.
Can you get this to me ?
Jeremy.
Comment 4 Jeremy Allison 2004-05-13 18:19:17 UTC
Created attachment 511 [details]
Patch for macromedia bug.

Patch for macromedia bug.
Comment 5 Jeremy Allison 2004-05-13 18:19:29 UTC
Ok, found and fixed the problem. Premature optimization in unix_convert()...
My bad :-(. Sorry.
Patch is attched.
Jeremy.
Comment 6 Gerald (Jerry) Carter 2004-05-18 05:32:09 UTC
*** Bug 1354 has been marked as a duplicate of this bug. ***
Comment 7 Kevin P. Fleming 2004-05-21 20:38:36 UTC
This bug also affects the "robocopy" utility from the Windows 2000/XP resource kits.
Comment 8 Gerald (Jerry) Carter 2004-05-25 05:59:40 UTC
also affects ARCSERVE backup agent from what 
I can tell
Comment 9 Edwin Groothuis 2004-06-12 01:40:19 UTC
Also affected Retrospect backup software. Patch 
http://samba.org/~jerry/patches/post-3.0.4/samba-3.0.4.patch fixed the problem.
Comment 10 Dick Visser 2004-07-28 02:45:49 UTC
oh no, this bug revives in 3.0.5 :(
Comment 11 Jeremy Allison 2004-07-28 15:28:32 UTC
This was specifically not addressed in 3.0.5 as that was a security release
*only*. This bug is fixed and will be addressed in 3.0.6 and above.
Jeremy.
Comment 12 Gerald (Jerry) Carter 2005-08-24 10:16:37 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.