Bug 1550 - [3.0.5] passdb/pdb_ldap.c: A function call is not allowed in a constant expression.
[3.0.5] passdb/pdb_ldap.c: A function call is not allowed in a constant expre...
Status: RESOLVED DUPLICATE of bug 1385
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.5
SGI IRIX
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 05:54 UTC by Jason Mader
Modified: 2005-02-07 09:56 UTC (History)
0 users

See Also:


Attachments
Patch (765 bytes, patch)
2004-07-22 14:44 UTC, The Written Word
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2004-07-22 05:54:26 UTC
(Bugzilla hasn't been updated to all 3.0.5 yet, but this is in the 3.0.5 release).

Compiling passdb/pdb_ldap.c
cc-1059 cc: ERROR File = passdb/pdb_ldap.c, Line = 1046
  A function call is not allowed in a constant expression.

                        LOGIN_CACHE cache_entry ={time(NULL),
                                                  ^

cc-1059 cc: ERROR File = passdb/pdb_ldap.c, Line = 1047
  A function call is not allowed in a constant expression.

                                                  pdb_get_acct_ctrl(sampass),
                                                  ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1047
  The expression used must have a constant value.

                                                  pdb_get_acct_ctrl(sampass),
                                                                    ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1048
  The expression used must have a constant value.

                                                  badcount, badtime};
                                                  ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1048
  The expression used must have a constant value.

                                                  badcount, badtime};
                                                            ^

cc-1164 cc: WARNING File = passdb/pdb_ldap.c, Line = 2539
  Argument of type "const char **" is incompatible with parameter of type
          "char **".

                            LDAP_SCOPE_SUBTREE, filter, attrs, 0, &result);
                                                        ^

5 errors detected in the compilation of "passdb/pdb_ldap.c".
*** Error code 2 (bu21)
Comment 1 The Written Word 2004-07-22 14:44:06 UTC
Created attachment 577 [details]
Patch

Non-constant initializer fix (not valid C89).
Comment 2 Volker Lendecke 2004-07-23 11:59:42 UTC

*** This bug has been marked as a duplicate of 1385 ***
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:56:08 UTC
originally against 3.0.5rc1 (which was 34.0.6rc1 due to the security release).