Bug 1385 - [passdb/pdb_ldap.c] LOGIN_CACHE cache_entry, compile errors on Irix,
[passdb/pdb_ldap.c] LOGIN_CACHE cache_entry, compile errors on Irix,
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.4
SGI IRIX
: P3 normal
: none
Assigned To: Tim Potter
:
: 1550 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 08:01 UTC by Jason Mader
Modified: 2005-08-24 10:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2004-05-26 08:01:30 UTC
I encounter the following errors on when compiling on Irix 6.5.23f with MIPSpro 7.4.2m compilers, 
affects Samba 3.0.4 and 3.0.5pre1.  The configure syntax I used was:
	env CC=cc CFLAGS="-O" ./configure --with-quotas --with-acl-support --with-libiconv=/opt


Compiling passdb/pdb_ldap.c
cc-1059 cc: ERROR File = passdb/pdb_ldap.c, Line = 1046
  A function call is not allowed in a constant expression.

                        LOGIN_CACHE cache_entry ={time(NULL),
                                                  ^

cc-1059 cc: ERROR File = passdb/pdb_ldap.c, Line = 1047
  A function call is not allowed in a constant expression.

                                                  pdb_get_acct_ctrl(sampass),
                                                  ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1047
  The expression used must have a constant value.

                                                  pdb_get_acct_ctrl(sampass),
                                                                    ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1048
  The expression used must have a constant value.

                                                  badcount, badtime};
                                                  ^

cc-1028 cc: ERROR File = passdb/pdb_ldap.c, Line = 1048
  The expression used must have a constant value.

                                                  badcount, badtime};
                                                            ^

cc-1164 cc: WARNING File = passdb/pdb_ldap.c, Line = 2539
  Argument of type "const char **" is incompatible with parameter of type
          "char **".

                            LDAP_SCOPE_SUBTREE, filter, attrs, 0, &result);
                                                        ^

5 errors detected in the compilation of "passdb/pdb_ldap.c".
*** Error code 2 (bu21)
Comment 1 Jeremy Allison 2004-05-26 10:44:43 UTC
Fixed - thanks.
Jeremy.
Comment 2 Volker Lendecke 2004-07-23 11:59:50 UTC
*** Bug 1550 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:26:57 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.