Bug 155 - Problem accessing directories with names containing ASCII 128+
Problem accessing directories with names containing ASCII 128+
Status: RESOLVED DUPLICATE of bug 153
Product: Samba 2.2
Classification: Unclassified
Component: File Services
All Linux
: P2 regression
: ---
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2003-06-12 03:40 UTC by mrjb
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description mrjb 2003-06-12 03:40:44 UTC

Figured this is a common bug but it doesnt seem reported yet.

We have an NT server that has directories with names that containing special
characters (c with cedille, a with tilde, and so on, anything above ascii 128),
having trouble accessing those directories from linux (Rh7.3).

Doing an ls shows for example Area Reservada (the accent doesn't show in ls but
on the NT server it's there). Changing to that dir even seems to work, but as
soon as I try to do an ls inside the dir I get stale NFS file handle.

By the way guys, there seems to be a similar problem copying files with accented
filenames from windows ME to windows 98 or v.v., without samba at all, so it
might just be a problem in the protocol. Just wish the people at my company
realized that using their native accented characters can be a problem ,) Anyway
them from their win machines seem to access the dir just fine. For now.

Keep up the good work!
Comment 1 Andrew Bartlett 2003-06-21 19:13:02 UTC
You need to configure the unix charset for whatever you have been using, or
convert names to UTF8 on the server.

*** This bug has been marked as a duplicate of 153 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:29:03 UTC
database cleanup