Bug 1509 - ntbackup (and likely others) doesn't work correctly against samba share
ntbackup (and likely others) doesn't work correctly against samba share
Status: RESOLVED DUPLICATE of bug 1404
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.5
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-07 15:24 UTC by Thomas M Steenholdt
Modified: 2005-02-07 09:47 UTC (History)
1 user (show)

See Also:


Attachments
level 10 log of the problem happening (266.91 KB, text/plain)
2004-07-07 15:25 UTC, Thomas M Steenholdt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas M Steenholdt 2004-07-07 15:24:33 UTC
Using ntbackup from win2k or winXP ws, an "access denied" error pops up when
selecting a samba share as the destination for the backup and attempting to
proceed. (X: is not a valid drive or you do not have access)

This wasn't the case with 3.0.2, but was also there in 3.0.3. (3.0.4 is unknown)

It appears that ntbackup tries to OPEN the share directory, but instead of
returning an error inticating that "this is a directory, not a file", samba
returns "access denied" which is then handled and displayed by the application!
(i may not be entirely correct about this - this is how it appears to me)

To try to reproduce, just use ntbackup.exe to create a backup file on any samba
share.
Comment 1 Thomas M Steenholdt 2004-07-07 15:25:18 UTC
Created attachment 560 [details]
level 10 log of the problem happening
Comment 2 Björn Jacke 2004-07-07 15:57:36 UTC

*** This bug has been marked as a duplicate of 1404 ***
Comment 3 Gerald (Jerry) Carter 2004-09-02 07:46:16 UTC
*** Bug 1707 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2005-02-07 09:47:49 UTC
originally against 3.0.5pre1 (which became 3.0.6pre1 due to security release))