Bug 1441 - smbtar doesn't work properly
smbtar doesn't work properly
Status: CLOSED DUPLICATE of bug 1325
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.2a
x86 Linux
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 05:39 UTC by Steve Winfield (mai address dead)
Modified: 2004-07-07 05:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Winfield (mai address dead) 2004-06-08 05:39:23 UTC
smbtar (/usr/bin/smbtar3) ignores both the '-d' or '-t' options and simply writes
'tar.out' to the local directory. For example, if i execute the following :

smbtar -v -s DEAN -d /mnt/sdb1/dean -x Drawings -u dean -p FgnbhYt

the verbose output reports that it can't find '\mnt\sdb1\dean' which of course
it won't if that's really what it's attempting to do. The backup itself works fine
but won't write to the correct location. On examining the code of 'smbtar3' i
can find that the value passed as the -d option '$cdcmd' does in fact appear to
hold the -d value i specified but i can't figure out how that value then becomes
'\mnt\sdb1\dean', i can't understand the script well enough to do that. Very
frustrating when this sort of thing happens.
Comment 1 Björn Jacke 2004-07-07 05:24:40 UTC
-t works fine for me -d not. it's an issue of smbclient

*** This bug has been marked as a duplicate of 1325 ***