Bug 1372 - Directory contents inconsistently reported to linux client
Directory contents inconsistently reported to linux client
Status: RESOLVED DUPLICATE of bug 1920
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.1
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 13:20 UTC by Reed Scarce (550 #5.1.0 Address rejected)
Modified: 2004-10-20 03:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reed Scarce (550 #5.1.0 Address rejected) 2004-05-21 13:20:33 UTC
Windows 2000 sp-3 shared directories -mounted by linux -accessed with ls, tar, 
du, and custom software -report their contents inconsistently and create other 
inconsistent output.  The examples given are from the a sub-directory of the 
mount as described.  The contents of the directory was created by

$for i in `seq 1 5000`; do touch $i; done

Obviously the test directory contains exactly 5000 files.  The windows explorer 
in a Win2k network client reports 5000 files. 

Directories with tangible files display similar results to those reported below.

from /etc/fstab
//10.10.10.10/SERVER-1 /svr1_mnt smbfs credentials=/etc/smb.credentials 1 1

$pwd
/svr1_mnt/data01/dir_test/test/fivethou

$cd ..

$ls fivethou > fiveths1  (repeated 5 times to separate files)
4965 4965 23722 fiveths1
4969 4969 23741 fiveths2
4973 4973 23772 fiveths3
4966 4966 23726 fiveths4
4954 4954 23668 fiveths5

(For sake of argument, the two files closest in size were chosen)

$diff fiveths1 fiveths4 | wc
87 140 674

$diff fiveths1 fiveths4 > ~diff_out1

$grep ^\< ~diff_out1 | wc
26 52 180

$grep ^\> ~diff_out1 | wc
27 54 186

The output file revealed many individual differences and some sequences of 
unlisted files between the two output files given here. I.E. diff returned:
<314
<3140
<3141 ... sequentially to 3149

likewise

>457
>4570
>4571
>4572 ... sequentially to 4578

Differences were reported from about line 1100 to 4800.  The differences were 
not evenly distributed within the output files.
Comment 1 Björn Jacke 2004-10-20 03:09:19 UTC

*** This bug has been marked as a duplicate of 1920 ***