Bug 1355 - Cannot connect to Printers share on Samba 3.0.2a from WinXP
Cannot connect to Printers share on Samba 3.0.2a from WinXP
Status: RESOLVED DUPLICATE of bug 114
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.2a
All Windows XP
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-15 14:23 UTC by Andreas K. Huettel
Modified: 2004-06-03 11:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Huettel 2004-05-15 14:23:03 UTC
Dear Developers, 

when upgrading from 2.2.8 to 3.0.2a-SuSE (as shipped in SuSE Linux 9.1), we've
encountered the following problem:

From an WinXP client, we can connect to the Samba server ("COKE") fine and
access the shared directories. The printers are shown in \\COKE. As soon as we
try to open the "Printers" subfolder, WinXP hangs. 

Samba logs several error messages, see below. Not sure what is relevant. Printer
drivers have been successfully (as far as I can see) uploaded via cupsaddsmb,
both CUPS drivers for WinNT/2000/XP and Adobe for Win95/98/ME. 

COKE is PDC as well (working fine afaik). On XP, the Internet Connection
Firewall is switched on (necessary since there is no department firewall). WinXP
is fully patched via Windows Update.

More info on request, I'll do my very best. (However, this is a production
system that was taken down for a Samba3 test run during the weekend.)

Log snippets (I hope this makes sense):

[2004/05/09 22:33:00, 0] smbd/server.c:main(748)
  smbd version 3.0.2a-SUSE started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004

[... some stuff like lib/iconv.c:utf8_pull(514) ...]

[2004/05/09 22:40:50, 1] smbd/ipc.c:api_fd_reply(292)
  api_fd_reply: INVALID PIPE HANDLE: 700b
[2004/05/09 22:41:20, 1] smbd/service.c:close_cnum(801)
  giotto (10.153.25.26) closed connection to service lehrstuhl
[2004/05/09 22:41:39, 1] smbd/service.c:make_connection_snum(619)
  giotto (10.153.25.26) connect to service netlogon initially as user netadmin
(uid=550, gid=103) (pid 10122)
[2004/05/09 22:42:53, 1] smbd/service.c:close_cnum(801)
  giotto (10.153.25.26) closed connection to service netlogon
[2004/05/09 22:43:08, 1] smbd/service.c:make_connection_snum(619)
  giotto (10.153.25.26) connect to service print$ initially as user netadmin
(uid=550, gid=103) (pid 10122)
[2004/05/09 22:49:41, 1] libsmb/cliconnect.c:cli_connect(1261)
  Error connecting to 10.153.25.26 (Connection timed out)
[2004/05/09 22:49:41, 0] rpc_server/srv_spoolss_nt.c:spoolss_connect_to_client(2513)
  spoolss_connect_to_client: unable to connect to SMB server on machine GIOTTO.
Error was : SUCCESS - 0.
[2004/05/09 22:49:41, 1] smbd/service.c:close_cnum(801)
  giotto (10.153.25.26) closed connection to service print$
[2004/05/09 22:50:12, 0] lib/util_sock.c:get_peer_addr(975)
  getpeername failed. Error was Transport endpoint is not connected
[2004/05/09 22:50:12, 0] lib/util_sock.c:get_peer_addr(975)
  getpeername failed. Error was Transport endpoint is not connected
[2004/05/09 22:50:12, 0] lib/access.c:check_access(328)
[2004/05/09 22:50:12, 0] lib/util_sock.c:get_peer_addr(975)
  getpeername failed. Error was Transport endpoint is not connected
  Denied connection from  (0.0.0.0)
[2004/05/09 22:50:12, 1] smbd/process.c:process_smb(883)
[2004/05/09 22:50:12, 0] lib/util_sock.c:get_peer_addr(975)
  getpeername failed. Error was Transport endpoint is not connected
  Connection denied from 0.0.0.0
[2004/05/09 22:50:12, 0] lib/util_sock.c:write_socket_data(411)
  write_socket_data: write failure. Error = Connection reset by peer
[2004/05/09 22:50:12, 0] lib/util_sock.c:write_socket(436)
  write_socket: Error writing 5 bytes to socket 22: ERRNO = Connection reset by peer
[2004/05/09 22:50:12, 0] lib/util_sock.c:send_smb(628)
  Error writing 5 bytes to client. -1. (Connection reset by peer)
Comment 1 Gerald (Jerry) Carter 2004-06-03 11:48:05 UTC
XP firewall configuration.  This is really a duplicate of 
bug 114 I believe.


*** This bug has been marked as a duplicate of 114 ***