Bug 1354 - HomeSite Connection Bug
HomeSite Connection Bug
Status: RESOLVED DUPLICATE of bug 1345
Product: Samba 3.0
Classification: Unclassified
Component: Upgrade
3.0.4
All Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-15 09:58 UTC by Robert Entwistle
Modified: 2005-11-14 09:31 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Entwistle 2004-05-15 09:58:39 UTC
When upgrading to Samba 3.0.4, trying to open files in Macromedia HomeSite 5.5
gives a "W:\ is not available Access is denied." error and will not let network
shares be opened.  Other programs do not exhibit this behavior including Windows
Explorer, Adobe Photoshop, and OpenOffice.

Temporary solution is to revert to 3.0.2.
Comment 1 Arunas 2004-05-17 00:05:08 UTC
With SAMBA 3.0.4 installed it is impossible to
access shares from HomeSite 5.x program, which is professional tool for web
development. SAMBA answers "Access denied", while all previous versions
worked OK. Here is what SAMBA write to its log (log level 3):


[2004/05/17 09:47:24, 3] smbd/process.c:process_smb(890)
  Transaction 34 of length 80
[2004/05/17 09:47:24, 3] smbd/process.c:switch_message(685)
  switch message SMBtconX (pid 22136)
[2004/05/17 09:47:24, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/05/17 09:47:24, 3] lib/access.c:check_access(313)
  check_access: no hostnames in host allow/deny list.
[2004/05/17 09:47:24, 2] lib/access.c:check_access(324)
  Allowed connection from  (194.176.40.131)
[2004/05/17 09:47:24, 3] smbd/service.c:make_connection_snum(457)
  Connect path is '/www' for service [www]
[2004/05/17 09:47:24, 3] lib/util_seaccess.c:se_access_check(251)
[2004/05/17 09:47:24, 3] lib/util_seaccess.c:se_access_check(252)
  se_access_check: user sid is S-1-5-21-466787236-1579449188-70613880-1000
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1001
  se_access_check: also S-1-1-0
  se_access_check: also S-1-5-2
  se_access_check: also S-1-5-11
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1009
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1021
[2004/05/17 09:47:24, 3] smbd/vfs.c:vfs_init_default(203)
  Initialising default vfs hooks
[2004/05/17 09:47:24, 3] lib/util_seaccess.c:se_access_check(251)
[2004/05/17 09:47:24, 3] lib/util_seaccess.c:se_access_check(252)
  se_access_check: user sid is S-1-5-21-466787236-1579449188-70613880-1000
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1001
  se_access_check: also S-1-1-0
  se_access_check: also S-1-5-2
  se_access_check: also S-1-5-11
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1009
  se_access_check: also S-1-5-21-466787236-1579449188-70613880-1021
[2004/05/17 09:47:24, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/05/17 09:47:24, 1] smbd/service.c:make_connection_snum(619)
  prometejas (194.176.40.131) connect to service www initially as user arunas
(uid=0, gid=0) (pid 22136)
[2004/05/17 09:47:24, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/05/17 09:47:24, 3] smbd/reply.c:reply_tcon_and_X(429)
  tconX service=WWW 
[2004/05/17 09:47:24, 3] smbd/process.c:process_smb(890)
  Transaction 35 of length 92
[2004/05/17 09:47:24, 3] smbd/process.c:switch_message(685)
  switch message SMBntcreateX (pid 22136)
[2004/05/17 09:47:24, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/05/17 09:47:24, 3] smbd/open.c:open_directory(1356)
  open_directory: unable to stat name = .. Error was Success
[2004/05/17 09:47:24, 3] smbd/error.c:error_packet(118)
  error packet at smbd/trans2.c(2222) cmd=162 (SMBntcreateX) NT_STATUS_ACCESS_DENIED
[2004/05/17 09:47:24, 3] smbd/process.c:process_smb(890)
  Transaction 36 of length 80
[2004/05/17 09:47:24, 3] smbd/process.c:switch_message(685)
  switch message SMBtrans2 (pid 22136)
[2004/05/17 09:47:24, 3] smbd/trans2.c:call_trans2qfilepathinfo(2331)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 1004
[2004/05/17 09:47:24, 3] smbd/trans2.c:call_trans2qfilepathinfo(2362)
  call_trans2qfilepathinfo . (fnum = -1) level=1004 call=5 total_data=0
[2004/05/17 09:47:24, 3] smbd/process.c:process_smb(890)
  Transaction 37 of length 92
[2004/05/17 09:47:24, 3] smbd/process.c:switch_message(685)
  switch message SMBntcreateX (pid 22136)
[2004/05/17 09:47:24, 3] smbd/open.c:open_directory(1356)
  open_directory: unable to stat name = .. Error was Success
[2004/05/17 09:47:24, 3] smbd/error.c:error_packet(118)
  error packet at smbd/trans2.c(2222) cmd=162 (SMBntcreateX) NT_STATUS_ACCESS_DENIED
Comment 2 Gerald (Jerry) Carter 2004-05-18 05:32:08 UTC

*** This bug has been marked as a duplicate of 1345 ***
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:31:17 UTC
database cleanup