Bug 13441 - vfs_fruit: delete 0 byte size streams if AAPL is enabled
vfs_fruit: delete 0 byte size streams if AAPL is enabled
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
unspecified
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-17 17:32 UTC by Ralph Böhme
Modified: 2018-10-05 10:16 UTC (History)
5 users (show)

See Also:


Attachments
Patch for 4.7 and 4.8 cherry-picked from master (12.13 KB, patch)
2018-07-07 12:53 UTC, Ralph Böhme
jra: review+
Details
Follow-up patch for 4.9, cherry-picked from master (4.50 KB, patch)
2018-09-04 09:28 UTC, Ralph Böhme
slow: review? (jra)
metze: review+
Details
Follow-up patch for 4.7 and 4.8, cherry-picked from master (4.50 KB, patch)
2018-09-04 09:29 UTC, Ralph Böhme
slow: review? (jra)
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Böhme 2018-05-17 17:32:57 UTC
macOS SMB server uses xattrs as storage backend for streams, directly exposing xattr get/set characteristics. Setting EOF on a stream to 0 just deletes the xattr as there's no 0-byte size xattr.

To be compatible with a macOS SMB server, we should behave the same for macOS client.

Have patch, need bugnumber...
Comment 1 Ralph Böhme 2018-07-07 12:53:26 UTC
Created attachment 14311 [details]
Patch for 4.7 and 4.8 cherry-picked from master
Comment 2 Jeremy Allison 2018-07-09 22:03:15 UTC
Reassigning to Karolin for inclusion in 4.8.next, 4.7.next.
Comment 3 Karolin Seeger 2018-07-12 10:54:44 UTC
(In reply to Jeremy Allison from comment #2)
Pushed to autobuild-v4-[8,7]-test.
Comment 4 Karolin Seeger 2018-07-12 11:01:35 UTC
(In reply to Karolin Seeger from comment #3)
Pushed to both branches.
Closing out bug report.

Thanks!
Comment 5 Ralph Böhme 2018-09-04 09:28:10 UTC
Created attachment 14470 [details]
Follow-up patch for 4.9, cherry-picked from master
Comment 6 Ralph Böhme 2018-09-04 09:29:21 UTC
Created attachment 14471 [details]
Follow-up patch for 4.7 and 4.8, cherry-picked from master

4.9 patch doesn't apply with git am, thus providing different patchset for 4.8 and 4.7.
Comment 7 Karolin Seeger 2018-09-04 10:15:11 UTC
(In reply to Ralph Böhme from comment #6)
Pushed to autobuild-v4-{9,8,7}-test.
Comment 8 Karolin Seeger 2018-09-06 07:03:27 UTC
Pushed to all branches.
Closing out bug report.

Thanks!
Comment 9 Ralph Böhme 2018-10-05 10:16:38 UTC
*** Bug 13636 has been marked as a duplicate of this bug. ***