Bug 134 - NT4 Migration
NT4 Migration
Status: RESOLVED DUPLICATE of bug 132
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0preX
All Linux
: P2 regression
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 12:06 UTC by Raphael Berghmans
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Berghmans 2003-05-27 12:06:12 UTC
Since two days I'm trying to migrate a whole NT4 PDC to Samba-3 with the
"net rpc vampire". 

Each user and computer accounts are correctly added in LDAP directory.
But for every account this message appears during the migration :

Primary group of xxxx has no mapping!

An other problem is that none of the 558 groups is added in LDAP
directory. Then, in my smb.conf I've added a "add group script" using
the smbldap-tool. This tool adds for every group a posix entry in LDAP.

But what about the Group mapping ? Howto add it automaticaly in LDAP
during the "vampire" ?

And last but not least when "vampire" has to add the member for each
group I get this error : 

utils/net_rpc_samsync.c:fetch_group_mem_info(558)
  Could not find global group xyz


My configuration is :

NT4 PDC with 1700 user accounts, 1500 computer accounts and 558 groups
Comment 1 Andrew Bartlett 2003-06-21 19:27:42 UTC
The 'add user script' and 'add group script' should create the posix user/group
in ldap, so that we can add the samba user to them.

A lot of things have been fixed in this code recently, but make sure you set:

idmap backend = ldap://my.ldap.server

to match the 'ldap' part of your passdb backend entry.

Comment 2 Andrew Bartlett 2003-06-24 05:23:01 UTC
I'm not sure if it's all fixed yet, but it's certainly the same as bug 132.

*** This bug has been marked as a duplicate of 132 ***
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:57:20 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:24:26 UTC
database cleanup