Bug 1335 - ctrl-alt-delete change password works, but gives error on windows side
Summary: ctrl-alt-delete change password works, but gives error on windows side
Status: RESOLVED DUPLICATE of bug 1303
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control (show other bugs)
Version: 3.0.2a
Hardware: All Solaris
: P3 normal
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-09 20:48 UTC by Russ Jury
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Jury 2004-05-09 20:48:31 UTC
I attempt to change my password from windows (ctrl-alt-delete), and it gives me 
the standard error "The system cannot change your password now because domain 
DOMAIN is not available".  However, the change does go through for both samba 
(using tdbsam backend) as well as Solaris (using /bin/passwd %u, samba server 
is NIS master).  I am fairly certain my "passwd chat" is correct, however was 
not able to get "passwd chat debug = yes" to work.  "unix password sync = yes" 
as well...

Output of log.smb when I hit 'OK' to change password: (moe is client machine, 
domain = DOMAIN, user = russj) -- this looks bad, but actually DOES work - just 
doesn't let windows user know that it worked.

[2004/05/09 22:42:42, 0] smbd/chgpasswd.c:check_oem_password(832)
  check_oem_password: incorrect password length (1319199709).
[2004/05/09 22:42:42, 1] rpc_server/srv_pipe.c:api_pipe_ntlmssp_verify(414)
  api_pipe_ntlmssp_verify: User [DOMAIN]\[russj] from machine MOE failed authent
ication on named pipe samr.
[2004/05/09 22:42:42, 0] smbd/chgpasswd.c:check_oem_password(832)
  check_oem_password: incorrect password length (1319199709).
[2004/05/09 22:42:45, 1] rpc_server/srv_pipe.c:api_pipe_ntlmssp_verify(414)
  api_pipe_ntlmssp_verify: User [DOMAIN]\[russj] from machine MOE failed authent
ication on named pipe samr.
[2004/05/09 22:42:45, 0] smbd/chgpasswd.c:check_oem_password(832)
  check_oem_password: incorrect password length (1319199709).
[2004/05/09 22:42:45, 1] rpc_server/srv_pipe.c:api_pipe_ntlmssp_verify(414)
  api_pipe_ntlmssp_verify: User [DOMAIN]\[russj] from machine MOE failed authent
ication on named pipe samr.
[2004/05/09 22:42:45, 0] smbd/chgpasswd.c:check_oem_password(832)
  check_oem_password: incorrect password length (1319199709).
Comment 1 Gerald (Jerry) Carter 2004-05-10 06:34:18 UTC

*** This bug has been marked as a duplicate of 1303 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:29:18 UTC
database cleanup