Bug 12779 - cli->server_os not filled correctly
cli->server_os not filled correctly
Status: RESOLVED DUPLICATE of bug 12824
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient
4.6.3
All All
: P5 normal
: ---
Assigned To: Stefan Metzmacher
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-08 10:40 UTC by Stefan Metzmacher
Modified: 2017-06-07 09:13 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2017-05-08 10:40:44 UTC
cli->server_os (and others) are never updated as they're always a valid pointer.

smb_bytes_pull_str() also produced wrong strings, due to an alignment bug.
Comment 1 Stefan Metzmacher 2017-06-07 08:30:29 UTC
*** Bug 12824 has been marked as a duplicate of this bug. ***
Comment 2 Andreas Schneider 2017-06-07 09:13:34 UTC
Sorry, the current patches already use the bug number #12824

*** This bug has been marked as a duplicate of bug 12824 ***