Bug 12824 - REGRESSION: smbclient doesn't print the session setup anymore
REGRESSION: smbclient doesn't print the session setup anymore
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient
4.6.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 12779 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 15:07 UTC by Andreas Schneider
Modified: 2017-06-20 10:57 UTC (History)
3 users (show)

See Also:


Attachments
patch for 4.6 (6.77 KB, patch)
2017-06-07 09:14 UTC, Andreas Schneider
metze: review-
Details
patch for 4.6 (9.89 KB, patch)
2017-06-13 09:30 UTC, Andreas Schneider
metze: review+
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2017-06-06 15:07:06 UTC
smbclient doesn't print the session setup anymore!

Domain=[SAMBA-TEST] OS=[XXX] Server=[XXX]

Patch will follow.
Comment 1 Stefan Metzmacher 2017-06-07 08:30:29 UTC

*** This bug has been marked as a duplicate of bug 12779 ***
Comment 2 Andreas Schneider 2017-06-07 09:12:54 UTC
Sorry, but the patches already use that bug number!

From bug #12799:

  cli->server_os (and others) are never updated as they're always a valid
  pointer.

  smb_bytes_pull_str() also produced wrong strings, due to an alignment bug.
Comment 3 Andreas Schneider 2017-06-07 09:13:34 UTC
*** Bug 12779 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Schneider 2017-06-07 09:14:08 UTC
Created attachment 13261 [details]
patch for 4.6
Comment 5 Stefan Metzmacher 2017-06-07 09:23:13 UTC
Comment on attachment 13261 [details]
patch for 4.6

Sorry, but the smb_bytes_pull_str() seems, wrong, it just works by luck.
Let's continue the discussion on the mailing list to get it right in master
first.
Comment 6 Andreas Schneider 2017-06-13 09:30:04 UTC
Created attachment 13269 [details]
patch for 4.6
Comment 7 Karolin Seeger 2017-06-19 09:06:43 UTC
Pushed to autobuild-v4-6-test.
Comment 8 Karolin Seeger 2017-06-20 10:57:31 UTC
(In reply to Karolin Seeger from comment #7)
Pushed to v4-6-test.
Closing out bug report.

Thanks!