Bug 12302 - incorrect uppercase/lowercase handling on LDAPattributes
incorrect uppercase/lowercase handling on LDAPattributes
Status: RESOLVED DUPLICATE of bug 12399
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.5.0
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-30 10:21 UTC by heinz hoelzl
Modified: 2016-11-11 07:04 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description heinz hoelzl 2016-09-30 10:21:04 UTC
Adding a new object, samba 4.5.0 on the first DC creates a ldapObject with the attribute name CN in lower case.
On the second DC samba via replication creates the object with upper case attribute name.


root@dc1: # samba-tool ldapcmp --filter=whenChanged ldap://dc1 ldap://DC2

* Comparing [DOMAIN] context...

* Objects to be compared: 12717

Comparing:
'CN=DC1,OU=Domain Controllers,DC=example,DC=net' [ldap://dc1]
'CN=DC1,OU=Domain Controllers,DC=example,DC=net' [ldap://DC2]
    Attributes found only in ldap://dc1:
        CN
    Attributes found only in ldap://DC2:
        cn
    FAILED

Comparing:
'CN=RID Set,CN=DC1,OU=Domain Controllers,DC=example,DC=net' [ldap://dc1]
'CN=RID Set,CN=DC1,OU=Domain Controllers,DC=example,DC=net' [ldap://DC2]
    Attributes found only in ldap://dc1:
        CN
    Attributes found only in ldap://DC2:
        cn
    FAILED

Comparing:
'CN=abc,CN=Users,DC=example,DC=net' [ldap://dc1]
'CN=abc,CN=Users,DC=example,DC=net' [ldap://DC2]
    Attributes found only in ldap://dc1:
        cn
    Attributes found only in ldap://DC2:
        CN
    FAILED

... snip ...
Comment 1 cihan ispanoglu 2016-10-03 11:49:56 UTC
I am also experiencing the same issue on Version 4.5.0.
Although it has nothing to with samba I am using SUSE Linux Enterprise Server 12 SP2 RC2 (x86_64).

Seeing the same lowercase and uppercase problem. It does not seem to interfere with samba functionality but needs to be tested throughly.


* Result for [DNSFOREST]: FAILURE

SUMMARY
---------

Attributes found only in ldap://microdc.xxx.xxx:

    cn
    dc

Attributes found only in ldap://sambadc.xxx.xxx:

    CN
    DC
ERROR: Compare failed: -1
Comment 2 Stefan Metzmacher 2016-11-11 07:04:09 UTC

*** This bug has been marked as a duplicate of bug 12399 ***