Bug 12599 - samba-tool ldapcmp case-sensitive for attributes
samba-tool ldapcmp case-sensitive for attributes
Status: RESOLVED DUPLICATE of bug 12302
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Tools
4.5.5
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-23 13:52 UTC by Harry Mills
Modified: 2017-02-23 14:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harry Mills 2017-02-23 13:52:18 UTC
Running  samba-tool ldapcmp against a 4.1 samba DC (DC-01) (installed sernet repo) and a 4.5.5 samba DC (DC-02) (compiled from src) both on CentOS 7

DC-01 was the original DC, DC-02 was joined as a secondary DC and synced its database from DC-01.

When running samba-tool ldapcmp -v  ldap://DC-01 ldap://DC-02 the comparison fails:

SUMMARY
---------

Attributes found only in ldap://DC-01:

    ou
    cn
    dc

Attributes found only in ldap://DC-02:

    OU
    CN
    DC

ERROR: Compare failed: -1

If I rewrite line 284 of lib64/python2.7/site-packages/samba/netcmd/ldapcmp.py

from: name = self.get_attribute_name(key)
to: name = self.get_attribute_name(key).lower()

then everything passes OK.
Comment 1 Björn Jacke 2017-02-23 14:32:11 UTC

*** This bug has been marked as a duplicate of bug 12302 ***