Bug 1224 - When atempting to upload printer drivers from win2ksp4 via apw drivers are uploaded, but access denied when atempting to save settings
When atempting to upload printer drivers from win2ksp4 via apw drivers are up...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.4
All FreeBSD
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 18:40 UTC by Dave
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2004-03-28 18:40:05 UTC
On the server created a print$ share with permissions of 775 owned by root and 
group of ntadmin. Added a user to the ntadmin group, logged in to a win2ksp4 
machine, navigated to my network places, print server, printers, then to my 
printer share, an hp5550, set up in /etc/printcap as a raw queue, right clicked 
on that, went to properties, left clicked. Selected no to the prompt to add a 
driver, which brought up the properties dialog, went to the advanced tab, and 
new driver button. Selected next, have disk, and gave the apw my drivers, it 
confirmed them, i hit finish, and it asked me to proceed even though there 
wasn't a digital signature, i said yes, drivers were installed succesfully, 
they showed up in the dialog box, then when i went to apply the changes i got 
the error:
"Printer settings could not be saved. Access is denied!"
In my log.satellite file i have:
[2004/03/27 14:23:50, 1] smbd/service.c:make_connection_snum(705)
  satellite (192.168.0.2) connect to service print$ initially as user dmehler 
(uid=1001, gid=1001) (pid 640)
[2004/03/27 14:23:58, 0] smbd/nttrans.c:call_nt_transact_ioctl(1990)
  call_nt_transact_ioctl(0x90100): Currently not implemented.
[2004/03/27 14:24:14, 1] smbd/service.c:make_connection_snum(705)
  satellite (192.168.0.2) connect to service print$ initially as user dmehler 
(uid=1001, gid=1001) (pid 640)
[2004/03/27 14:24:14, 1] smbd/service.c:close_cnum(887)
  satellite (192.168.0.2) closed connection to service print$
[2004/03/27 14:24:14, 1] smbd/service.c:make_connection_snum(705)
  satellite (192.168.0.2) connect to service print$ initially as user dmehler 
(uid=1001, gid=1001) (pid 640)
[2004/03/27 14:24:14, 1] smbd/service.c:close_cnum(887)
  satellite (192.168.0.2) closed connection to service print$
[2004/03/27 14:25:07, 1] smbd/service.c:close_cnum(887)
  satellite (192.168.0.2) closed connection to service print$
And i'm not sure if this is related but in my log.smbd file i am getting this:
[2004/03/27 13:59:32, 1] smbd/files.c:file_init(186)
  file_init: Information only: requested 10000 open files, 5459 are available.

Thank you for reading this.
Dave.
Comment 1 Gerald (Jerry) Carter 2004-05-07 07:12:00 UTC
I think this is a duplicate of bug 1293.  Pleas try the patch
attached to that report.
Comment 2 Dave 2004-05-09 12:55:39 UTC
Hello Jerry, I have tried samba 3.0.4 and am getting the same results, settings 
are not saving when i click apply. Please let me know any additional 
information i can provide.
Dave.
Comment 3 Gerald (Jerry) Carter 2004-05-27 03:59:40 UTC
Dave, did you ever send me your smb.conf ?  If not, please
attach it to the bug report.
Comment 4 Gerald (Jerry) Carter 2004-05-29 23:01:33 UTC
Dave, it could be an issue with this driver when using a 
NULL device mode.  Try setting 'default devmode = yes' in the 
printer's service definition in smb.conf.  

There's no ACCESS_DENIED or other telltale messages in 
the log files you sent.
Comment 5 Dave 2004-06-02 20:49:22 UTC
Hi Jerry,
Thanks for your reply. Unfortunately i added the parameter:
default devmode = yes
to the printer definition in smb.conf as you indicated and i got the same 
results. The printer driver can not be saved messages is only coming from the 
windows clients as far as i can tell.
From reading smb.conf i thought for sure the default devmode would do it, since 
i was noticing the behavior indicated in the man page, repeated atempts to add 
the printer would eventually produce segfaults in explorer.exe on my windows 
boxes.
Please let me know if i can help further.
Thanks.
Dave.
(In reply to comment #4)
> Dave, it could be an issue with this driver when using a 
> NULL device mode.  Try setting 'default devmode = yes' in the 
> printer's service definition in smb.conf.  
> There's no ACCESS_DENIED or other telltale messages in 
> the log files you sent.

Comment 6 Gerald (Jerry) Carter 2004-06-02 21:15:08 UTC
Can you send me a tarball of the drivers.
Send then to me directly.  Thanks.
Comment 7 Gerald (Jerry) Carter 2004-06-09 09:23:21 UTC
Dave,

I grabbed the latest dj 5550 drivers for win2k 
from hp.com.  I had no problems installing these
from a 2ksp4 client onto Samba (Version 3.0.5pre2-SVN-build-1011).

I was also not prompted about a lack of a dig sign. 
on the dirvers so maybe you should make sure you have the 
2k drivers.  In any case, there doesn't appear to be a 
bug here.  At least nothing that we can do anything about.
Maybe something specific about that driver.


Comment 8 Dave 2004-07-10 21:26:46 UTC
Hi Jerry,
Thanks for the help on this bug. Your suggestion of the devmode parameter 
setting did it. I've tested the fix on samba 3.0.5 with both Linux and FreeBSD, 
with both the cups and lpd spooling systems. Included below is a recursive 
permissions listing of my print$ share, needed for access and the lines 
relating to printers in my smb.conf file. Again thanks much.
Dave.

[global]
cups options = "raw"

[printers]
comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes
default devmode = yes

[print$]
	path = /usr/local/samba/printers
	read only = no
	guest ok = yes
	inherit permissions = yes
	force user = dmehler
	write list = +ntadmin, root
default devmode = yes


permissions listing
drwxrwsr-x  2 dmehler  ntadmin   512 Jun 25 01:18 printers/
total 4
drwxrwsr-x  2 dmehler  ntadmin   512 Jun 25 01:18 COLOR/
drwxrwsr-x  3 root     ntadmin  1024 Jun 25 01:18 W32X86/

printers/COLOR:
total 4
-rw-rw-r--  1 dmehler  ntadmin  3144 Dec 22  1998 sRGB Color Space Profile.icm

printers/W32X86:
total 2
drwxrwsr-x  2 dmehler  ntadmin  1024 Jun 25 01:04 3/

printers/W32X86/3:
total 14344
-rw-rw-r--  1 dmehler  ntadmin    55665 Dec  9  2002 hpf4a607.dat
-rw-rw-r--  1 dmehler  ntadmin    92575 Dec  9  2002 hpfuih07.hlp
-rw-rw-r--  1 dmehler  ntadmin   200704 Dec  9  2002 hpz2ku07.dll
-rw-rw-r--  1 dmehler  ntadmin   241664 Dec  9  2002 hpzcfg07.exe
-rw-rw-r--  1 dmehler  ntadmin   208896 Dec  9  2002 hpzcoi07.dll
-rw-rw-r--  1 dmehler  ntadmin   270336 Dec  9  2002 hpzcon07.dll
-rw-rw-r--  1 dmehler  ntadmin   843776 Dec  9  2002 hpzeng07.exe
-rw-rw-r--  1 dmehler  ntadmin    81920 Dec  9  2002 hpzflt07.dll
-rw-rw-r--  1 dmehler  ntadmin   204800 Dec  9  2002 hpzime07.dll
-rw-rw-r--  1 dmehler  ntadmin   196608 Dec  9  2002 hpzjui07.dll
-rw-rw-r--  1 dmehler  ntadmin   147512 Dec  9  2002 hpzlnt07.dll
-rw-rw-r--  1 dmehler  ntadmin   294912 Dec  9  2002 hpzntp07.dll
-rw-rw-r--  1 dmehler  ntadmin   319488 Dec  9  2002 hpzpre07.exe
-rw-rw-r--  1 dmehler  ntadmin  9060352 Dec  9  2002 hpzr3207.dll
-rw-rw-r--  1 dmehler  ntadmin   372736 Dec  9  2002 hpzres07.dll
-rw-rw-r--  1 dmehler  ntadmin   409600 Dec  9  2002 hpzrp307.dll
-rw-rw-r--  1 dmehler  ntadmin   372736 Dec  9  2002 hpzstc07.exe
-rw-rw-r--  1 dmehler  ntadmin   172032 Dec  9  2002 hpzstw07.exe
-rw-rw-r--  1 dmehler  ntadmin    73728 Dec  9  2002 hpztbi07.dll
-rw-rw-r--  1 dmehler  ntadmin   188416 Dec  9  2002 hpztbu07.exe
-rw-rw-r--  1 dmehler  ntadmin   430080 Dec  9  2002 hpztbx07.exe
-rw-rw-r--  1 dmehler  ntadmin   155699 Dec  9  2002 hpzvip07.dll
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:24:25 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.