Bug 1192 - smbd internal error with print service
smbd internal error with print service
Status: RESOLVED DUPLICATE of bug 1147
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 05:02 UTC by J. Schwender
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J. Schwender 2004-03-16 05:02:22 UTC
Using two similar printer names like 'ppolycs' and 'ppolycs2'. When i try to add
the print queue from the windows dialog 'add printer queue' to a printer i get a
message stating 'please choose a valid queue' and the action fails. When i
rename one of the printers no error occurs.

Samba 3.0.2, compiled with cups-libs 1.1.20 using LDAP for auth.
On th RH Advanced Server 7.3 we have:
openldap-2.0.23-4, openldap-clients-2.0.23-4, openldap12-1.2.13-3,
openldap-devel-2.0.23-4, php-ldap-4.1.2-7.3.6, auth_ldap-1.6.0-4
openldap-servers-2.0.23-4, nss_ldap-189-2
Kernel 2.4.21-xfs, glibc 2.2.5

  get_stored_queue_info: failed to find changed job = 1932488297
[2004/03/16 13:12:38, 10] printing/printing.c:remove_from_jobs_changed(1437)
  remove_from_jobs_changed: removed jobid 1932488297
[2004/03/16 13:12:38, 5] printing/printing.c:get_stored_queue_info(2187)
  get_stored_queue_info: changed job = 6578797
[2004/03/16 13:12:38, 5] printing/printing.c:get_stored_queue_info(2190)
  get_stored_queue_info: failed to find changed job = 6578797
[2004/03/16 13:12:38, 10] printing/printing.c:remove_from_jobs_changed(1437)
  remove_from_jobs_changed: removed jobid 6578797
[2004/03/16 13:12:38, 5] printing/printing.c:get_stored_queue_info(2187)
  get_stored_queue_info: changed job = 0
[2004/03/16 13:12:38, 5] printing/printing.c:get_stored_queue_info(2190)
  get_stored_queue_info: failed to find changed job = 0
[2004/03/16 13:12:38, 10] printing/printing.c:remove_from_jobs_changed(1437)
  remove_from_jobs_changed: removed jobid 0
[2004/03/16 13:12:38, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/03/16 13:12:38, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 1042 (3.0.2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/03/16 13:12:38, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/03/16 13:12:38, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/03/16 13:12:38, 0] lib/util.c:smb_panic(1407)
  BACKTRACE: 14 stack frames:
   #0 smbd(smb_panic+0x14e) [0x819476e]
   #1 smbd [0x81847d7]
   #2 smbd [0x42029188]
   #3 smbd(print_queue_status+0x146) [0x81ae916]
   #4 smbd [0x808a9f7]
   #5 smbd(api_reply+0x28f) [0x80905af]
   #6 smbd(reply_trans+0x995) [0x8088e45]
   #7 smbd [0x80bda39]
   #8 smbd [0x80bdade]
   #9 smbd(process_smb+0x1a7) [0x80bdde7]
   #10 smbd(smbd_process+0x151) [0x80be7d1]
   #11 smbd(main+0x6c3) [0x81f1843]
   #12 smbd(__libc_start_main+0x95) [0x42017589]
   #13 smbd(ldap_msgfree+0x6d) [0x8076c11]

reminds me a little to bug 990.
Comment 1 Gerald (Jerry) Carter 2004-03-16 07:39:31 UTC

*** This bug has been marked as a duplicate of 1147 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:26:57 UTC
database cleanup