Bug 990 - lib/fault.c:fault_report
lib/fault.c:fault_report
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2
All Linux
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 08:09 UTC by Flavio Moreira
Modified: 2005-11-14 09:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Flavio Moreira 2004-01-19 08:09:12 UTC
[2004/01/19 11:02:02, 1] smbd/service.c:make_connection_snum(705)
  comercial2 (192.168.200.7) connect to service disco_c initially as user 
nobody (uid=65534, gid=65534) (pid 7780)
[2004/01/19 13:24:08, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/01/19 13:24:08, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 7780 (3.0.1-Debian)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/01/19 13:24:08, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/01/19 13:24:08, 0] lib/util.c:smb_panic(1390)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 7780]
/usr/share/samba/panic-action: line 48: mail: command not found
[2004/01/19 13:24:08, 0] lib/util.c:smb_panic(1398)
  smb_panic(): action returned status 127
[2004/01/19 13:24:08, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/01/19 13:24:08, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 15 stack frames:
   #0 /usr/sbin/smbd(smb_panic+0x101) [0x81bdc31]
   #1 /usr/sbin/smbd [0x81ac017]
   #2 /lib/libc.so.6 [0x401e2498]
   #3 /lib/libc.so.6 [0x4022ab48]
   #4 /lib/libc.so.6(malloc+0x93) [0x40229d33]
   #5 /usr/sbin/smbd(Realloc+0x88) [0x81bcde8]
   #6 /usr/sbin/smbd [0x80aef12]
   #7 /usr/sbin/smbd(reply_trans2+0x750) [0x80b4410]
   #8 /usr/sbin/smbd [0x80c7dca]
   #9 /usr/sbin/smbd [0x80c8030]
   #10 /usr/sbin/smbd(process_smb+0x8c) [0x80c823c]
   #11 /usr/sbin/smbd(smbd_process+0x168) [0x80c8eb8]
   #12 /usr/sbin/smbd(main+0x4bc) [0x8228cfc]
   #13 /lib/libc.so.6(__libc_start_main+0xc6) [0x401ceda6]
   #14 /usr/sbin/smbd(ldap_msgfree+0x8d) [0x8077121]
[2004/01/19 13:24:08, 1] smbd/service.c:make_connection_snum(705)
  comercial2 (192.168.200.7) connect to service disco_c initially as user 
nobody (uid=65534, gid=65534) (pid 8135)
Comment 1 Bastien Nocera 2004-02-25 02:43:57 UTC
We can reproduce this problem with RHEL 3's Samba (version 3.0.2-2rc2.3E).
Exact same backtrace.

Could somebody update the version number to match the new backtrace?

See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114303
Comment 2 Gerald (Jerry) Carter 2004-03-08 09:34:29 UTC
Please provide more details on how to reproduce this (what 
was the client doing)?  Or a backtrace that includes 
debugging symbols?  Or a level 10 debug log.  Thanks.
Comment 3 Gerald (Jerry) Carter 2004-03-16 11:54:14 UTC
This looks like a memory corrupt caused by convert_string bugs 
fixed in 3.0.2a.  Please reopen if you can reproduce on the 
final 3.0.2a build.  Thanks.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:25:17 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:29:03 UTC
database cleanup