Bug 11685 - Windows 7 cannot join Samba classic domain controller
Windows 7 cannot join Samba classic domain controller
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Other
All Linux
: P5 major
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
: 7837 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2016-01-21 15:17 UTC by fthynne
Modified: 2016-02-15 10:12 UTC (History)
2 users (show)

See Also:

smb.conf differences from defaults (2.23 KB, text/plain)
2016-01-21 15:17 UTC, fthynne
no flags Details
log and test results from Windows 7 (3.81 KB, text/plain)
2016-01-26 16:15 UTC, fthynne
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fthynne 2016-01-21 15:17:43 UTC
Created attachment 11783 [details]
smb.conf differences from defaults

Attempting to replace a Samba 3.0 PDC (10 years old)
Configuring Samba 4.1.6 as a classic PDC with file shares.
Max protocol has been limited to NT1.
Recommended Registry changes to Windows 7 have been applied
Windows XP clients can join the domain but Windows 7 cannot.
Windows 7 clients can see and use the shares.
Dialogue when attempting to join Windows 7 is all UDP (ports 138 and 137).
No errors observed in Windows event logs. 
Dialogue when joining Windows XP changes from UDP to TCP (ports 139 and 445) after about 20 interactions.
Dialogue when Windows 7 is viewing shares (without joining) is all TCP (port 445).
Comment 1 fthynne 2016-01-26 16:15:06 UTC
Created attachment 11789 [details]
log and test results from Windows 7
Comment 2 fthynne 2016-01-26 16:30:44 UTC
This bug is similar to bug 7837 reported on 2010-12-03 against Samba 3 and never resolved.

That bug report was raised again as 7839 and 7840 by the same submitter. The duplicates were marked RESOLVED as duplicates but the original bug is still has NEW status, five years later.

The persistence of this bug conflicts with the assertion that supported versions of Samba support Windows 7 equally with older versions of Windows.

Please note that I have not attempted to use Samba 4 as an AD domain controller because sharing files and running AD on the same server is specifically not recommended. The server being replaced carried out NT PDC and file-sharing functions without trouble.

I have attached log material and test results from Windows 7 that I had not discovered when raising this bug.
Comment 3 fthynne 2016-02-14 23:03:24 UTC
This bug is resolved as INVALID. The symptoms were caused by an incorrect change to Microsoft Windows 7 (a mis-spelt registry key). 

Confusion was caused by bug 7837, reporting similar symptoms, remaining with status unresolved.
Comment 4 Björn Jacke 2016-02-15 10:12:28 UTC
*** Bug 7837 has been marked as a duplicate of this bug. ***