Bug 1091 - file timestamp on samba share residing on zSeries Linux
file timestamp on samba share residing on zSeries Linux
Status: RESOLVED DUPLICATE of bug 140
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.8a
All Linux
: P3 normal
: ---
Assigned To: Jim McDonough
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 07:14 UTC by Christian Demmer
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments
Samba configuration file (1.74 KB, text/plain)
2004-02-17 07:15 UTC, Christian Demmer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Demmer 2004-02-17 07:14:55 UTC
Hardware Environment: zSeries hardware, running 64 Bit Linux

Software Environment: SuSE Linux Enterprise Server 8 with service pack 3, samba
is installed as SuSE rpm package version 2.2.8a-97, client is windows 2000
advanced server with service pack
4, microsoft office (excel) 2002 with service pack 2

setup:
Linux on zSeries is providing samba shares to windows clients, the drives are
mapped using the "net use <drive>:" command

Steps to Reproduce:
1. on the samba share (on zSeries) reside two files: one excel file, one pdf
document (with normal timestamps: January 23, 2004 for the excel file and
October 13, 2003 for the pdf file)
2. from the windows 2000 client open the excel sheet and use "insert -> objects
-> Create from file" and use the pdf document and insert it into the execel sheet
3. even without saving the excel file, the timestamp of the pdf document changes!

Actual Results:
in windows explorer there is no timestamp for the pdf file shown, in the
propertoes dialog of the file the "modified date" is January 1, 1601 !!!
in linux a "ls -la" shows a timestamp of May 28, 60056.

Expected Results:
correct timestamps should be displayed

Additional Information:
only appears on systems running on zSeries 64-Bit not on 31-Bit systems

Linux kernel is 2.4.21-75 as provided by SuSE

the problem is reproducable on a clean install of SLES 8 64-Bit on zSeries

I can provide the smb.conf file if needed.
Comment 1 Christian Demmer 2004-02-17 07:15:45 UTC
Created attachment 406 [details]
Samba configuration file
Comment 2 Jim McDonough 2004-02-17 14:15:54 UTC
Ok, officially, this bug will not be fixed because it is in 2.2.  The problem
has been fixed in 3.0.  If you need to have suse fix their RPMs, please contact
them.  The problem can be found my comparing the 2.2.8a source,
source/lib/time.c:303 to 3.0 current source, same file, line 311.  3.0 takes
into account the possibility of a 64-bit time_t.

This is also a duplicate of #140.

*** This bug has been marked as a duplicate of 140 ***
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:31:24 UTC
database cleanup