Bug 10570 - Realmd - Received invalid or unsupported Netlogon data from server
Realmd - Received invalid or unsupported Netlogon data from server
Status: RESOLVED DUPLICATE of bug 10524
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.1.7
x86 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-27 23:31 UTC by Liban Hannan
Modified: 2014-04-28 03:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Liban Hannan 2014-04-27 23:31:29 UTC
When trying to join an Samba AD domain with realmd I get the following error:

! Received invalid or unsupported Netlogon data from server


After finding the following email -
https://lists.samba.org/archive/samba-technical/2013-October/095606.html

It seems that Samba does not respond to netlogon queries over tcp, whereas Microsoft AD does (on Windows Server 2003 and later).

This can be verified using the following command -

ldapsearch -h dc1.samdom.example.com -x -b '' -s base "(&(NtVer=\06\00\00\00)(AAC=\00\00\00\00))" NetLogon

This returns no results -

# extended LDIF
#
# LDAPv3
# base <> with scope baseObject
# filter: (&(NtVer=\06\00\00\00)(AAC=\00\00\00\00))
# requesting: NetLogon 
#

# search result
search: 2
result: 0 Success

# numResponses: 1
Comment 1 Stefan Metzmacher 2014-04-28 03:28:42 UTC

*** This bug has been marked as a duplicate of bug 10524 ***