Bug 10524 - samba returns 0 results to the LDAP query with filter (&(&(DnsDomain=NETAPP.TEST)(Host=STORE-SIM))(NtVer=0x00000006))
samba returns 0 results to the LDAP query with filter (&(&(DnsDomain=NETAPP.T...
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Other
4.1.6
All All
: P5 major
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 10570 (view as bug list)
Depends on:
Blocks: 10077
  Show dependency treegraph
 
Reported: 2014-03-29 11:42 UTC by Bruno Fernandes
Modified: 2014-05-19 09:00 UTC (History)
3 users (show)

See Also:


Attachments
netapp/win2008R2 network dump (87.05 KB, application/octet-stream)
2014-04-19 11:14 UTC, Bruno Fernandes
no flags Details
netapp/samba4 network dump (5.62 KB, application/octet-stream)
2014-04-19 11:14 UTC, Bruno Fernandes
no flags Details
patches cherry-picked from master for 4.1 (108.49 KB, patch)
2014-04-28 08:31 UTC, Andrew Bartlett
no flags Details
patches cherry-picked from master for 4.1 (107.99 KB, patch)
2014-04-28 08:34 UTC, Andrew Bartlett
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Fernandes 2014-03-29 11:42:29 UTC
I’m trying to add a NetApp Simulator (Data Ontap 8.1.4) to a Samba 4.1.6 domain and it is failing with the message “Setup cannot connect to an LDAP server for the NETAPP.TEST active directory domain, and so cannot continue”.

I compared network packets exchanged between netapp/samba and netapp/win2008R2 and the difference is that samba returns 0 results to the query filter (&(&(DnsDomain=NETAPP.TEST)(Host=STORE-SIM))(NtVer=0x00000006)).

Both tcpdumps are attached.


Bruno Fernandes
Comment 1 Stefan Metzmacher 2014-04-18 20:47:07 UTC
There're no attachments...
Comment 2 Bruno Fernandes 2014-04-19 11:14:31 UTC
Created attachment 9860 [details]
netapp/win2008R2 network dump
Comment 3 Bruno Fernandes 2014-04-19 11:14:59 UTC
Created attachment 9861 [details]
netapp/samba4 network dump
Comment 4 Bruno Fernandes 2014-04-19 11:16:11 UTC
Hi,


Both tcpdumps are attached now.


Bruno Fernandes
Comment 5 Stefan Metzmacher 2014-04-28 03:28:42 UTC
*** Bug 10570 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Bartlett 2014-04-28 08:31:12 UTC
Created attachment 9881 [details]
patches cherry-picked from master for 4.1

Attached are the patches from git master for exactly this issue.
Comment 7 Andrew Bartlett 2014-04-28 08:34:26 UTC
Created attachment 9882 [details]
patches cherry-picked from master for 4.1

(small correction to patch, I ran git format-patch to exported it with -s, and should not have)

Please confirm this fixes your issue, and then it can go into the next Samba 4.1 release.
Comment 8 Liban Hannan 2014-04-28 23:55:51 UTC
(In reply to comment #7)
> Created attachment 9882 [details]
> patches cherry-picked from master for 4.1
> 
> (small correction to patch, I ran git format-patch to exported it with -s, and
> should not have)
> 
> Please confirm this fixes your issue, and then it can go into the next Samba
> 4.1 release.

I can confirm that the patches fix the problem I reported - realmd works and ldapsearch returns netlogon data.
Comment 9 Karolin Seeger 2014-04-29 08:27:41 UTC
Pushed to autobuild-v4-1-test.

Please note that one patch added whitespace errors and avoid it in future:
Applying: s4:dsdb: Move cldap netlogon functions into samdb/ldb_modules
/data/git/samba/v4-1-test/.git/rebase-apply/patch:537: trailing whitespace.
/* 
/data/git/samba/v4-1-test/.git/rebase-apply/patch:544: trailing whitespace.
   
/data/git/samba/v4-1-test/.git/rebase-apply/patch:549: trailing whitespace.
   
/data/git/samba/v4-1-test/.git/rebase-apply/patch:554: trailing whitespace.
   
/data/git/samba/v4-1-test/.git/rebase-apply/patch:668: trailing whitespace.
						 NULL, LDB_SCOPE_SUBTREE, 
warning: squelched 9 whitespace errors
warning: 14 lines add whitespace errors.
Applying: libcli/cldap: Add utility to create netlogon filter
Applying: s4:torture/ldap: Add test for netlogon over tcp
/data/git/samba/v4-1-test/.git/rebase-apply/patch:382: trailing whitespace.
/* 
/data/git/samba/v4-1-test/.git/rebase-apply/patch:386: trailing whitespace.
   
/data/git/samba/v4-1-test/.git/rebase-apply/patch:389: trailing whitespace.
    
/data/git/samba/v4-1-test/.git/rebase-apply/patch:394: trailing whitespace.
   
/data/git/samba/v4-1-test/.git/rebase-apply/patch:399: trailing whitespace.
   
warning: squelched 2 whitespace errors
warning: 7 lines add whitespace errors.
Comment 10 Bruno Fernandes 2014-04-29 08:45:45 UTC
Hi,

It's working with me too.

Good work!


Thank you.

Regards,
BF
Comment 11 Karolin Seeger 2014-05-19 09:00:53 UTC
Pushed to v4-1-test.
Closing out bug report.

Thanks!