Bug 10436 - cancel fsp->oplock_timeout in downgrade_file_oplock()
cancel fsp->oplock_timeout in downgrade_file_oplock()
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
unspecified
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 10428 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-11 11:08 UTC by Stefan Metzmacher
Modified: 2014-02-19 13:08 UTC (History)
2 users (show)

See Also:


Attachments
Patch for v4-1-test (1.07 KB, patch)
2014-02-11 11:09 UTC, Stefan Metzmacher
vl: review+
jra: review+
Details
Patch for v4-0-test (1.07 KB, patch)
2014-02-11 11:10 UTC, Stefan Metzmacher
vl: review+
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2014-02-11 11:08:29 UTC
[2014/02/11 11:14:12.942296,  0] ../source3/smbd/oplock.c:333(oplock_timeout_handler)
  Oplock break failed for file apps/putty_057.exe -- replying anyway

Messages like this are filling the logs at 0, even if the
client downgraded the oplock to level 2.
Comment 1 Stefan Metzmacher 2014-02-11 11:09:23 UTC
Created attachment 9675 [details]
Patch for v4-1-test
Comment 2 Stefan Metzmacher 2014-02-11 11:10:10 UTC
Created attachment 9676 [details]
Patch for v4-0-test
Comment 3 Volker Lendecke 2014-02-11 15:11:01 UTC
Karo, please pick for 4.1 and 4.0.

Thanks,

Volker
Comment 4 Karolin Seeger 2014-02-14 19:12:45 UTC
Pushed to autobuild-v4-1-test and autobuild-v4-0-test.
Comment 5 Karolin Seeger 2014-02-16 16:16:47 UTC
Pushed to v4-1-test and v4-0-test.
Closing out bug report.

Thanks!
Comment 6 Nikolay Shopik 2014-02-19 13:08:47 UTC
*** Bug 10428 has been marked as a duplicate of this bug. ***