Bug 10428 - Oplock break failed error cause data corruption
Oplock break failed error cause data corruption
Status: RESOLVED DUPLICATE of bug 10436
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.1.3
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-07 13:08 UTC by Nikolay Shopik
Modified: 2014-02-19 13:08 UTC (History)
1 user (show)

See Also:


Attachments
tcpdump of samba session (82.88 KB, application/octet-stream)
2014-02-07 13:08 UTC, Nikolay Shopik
no flags Details
level 10 log (1.70 MB, application/zip)
2014-02-19 09:19 UTC, Georg Weickelt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolay Shopik 2014-02-07 13:08:09 UTC
Created attachment 9654 [details]
tcpdump of samba session

We are upgraded from 3.6.6 on debian to 4.1.3 and notice some files become corrupted. After log investigation I notice there is error

"Oplock break failed for file main kampf.xlsx -- replying anyway"
popsup usually 10 seconds later after opening file

Googling shows up 4.1.4 also having same issue - https://bugs.freenas.org/issues/4035

So far I tried "blocking locks = no" which gives no effect.

It seems weird have some oplock break failing as only 1 user open file, samba locking itself?

I've attaching tcpdump when I open file I see this error (captured on client side)
Comment 1 Georg Weickelt 2014-02-19 09:19:27 UTC
Created attachment 9693 [details]
level 10 log

opening some files to show the problem
Comment 2 Georg Weickelt 2014-02-19 09:22:18 UTC
The log was captured on version 4.1.4-20.1-3183-SUSE-oS12.3-x86_64.
Files are (not yet?) corrupted.
Comment 3 Georg Weickelt 2014-02-19 09:34:24 UTC
looks as if the problem is already fixed in 4.0.15
* BUG 10436: smbd: Fix an ancient oplock bug.

Thanks!
Comment 4 Volker Lendecke 2014-02-19 10:04:01 UTC
(In reply to comment #3)
> looks as if the problem is already fixed in 4.0.15
> * BUG 10436: smbd: Fix an ancient oplock bug.
> 
> Thanks!

Yep, I was just about to reply to this. Please close this bug if your problem is fixed with 4.0.15 and the pending next 4.1 release.

Thanks,

Volker
Comment 5 Nikolay Shopik 2014-02-19 13:08:47 UTC
We seen corrupted files only if bytelocks are used (DB file accessed by multiply copies of application). No corruption happend to single user access documents.

Is it possible that "oplock break failed" cause this? Mark dup as for now.

*** This bug has been marked as a duplicate of bug 10436 ***