Bug 10102 - net SIGSEGV when trying to join ADS
net SIGSEGV when trying to join ADS
Status: RESOLVED DUPLICATE of bug 10073
Product: Samba 4.0
Classification: Unclassified
Component: Tools
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2013-08-22 07:13 UTC by Milan Kerslager
Modified: 2013-09-10 09:53 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kerslager 2013-08-22 07:13:32 UTC
I have Fedora 19 with latest updates installed. I'm trying to join domain which is provided by Samba server. The station is able to find domain controller:

# net lookup dc oalib.cz

But then when using net command:

[root@pitoma ~]# gdb net
GNU gdb (GDB) Fedora (7.6-34.fc19)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /usr/bin/net...Reading symbols from /usr/lib/debug/usr/bin/net.debug...done.
(gdb) run ads join -U root oalib.cz
Starting program: /usr/bin/net ads join -U root oalib.cz
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Enter root's password:

Program received signal SIGSEGV, Segmentation fault.
strupper_m (s=s@entry=0x0) at ../source3/lib/util_str.c:562
562		while (*s && !(((unsigned char)s[0]) & 0x80)) {
Missing separate debuginfos, use: debuginfo-install audit-libs-2.3.2-1.fc19.x86_64 avahi-libs-0.6.31-11.fc19.x86_64 cups-libs-1.6.3-4.fc19.x86_64 cyrus-sasl-lib-2.1.26-9.fc19.x86_64 dbus-libs-1.6.12-1.fc19.x86_64 keyutils-libs-1.5.5-4.fc19.x86_64 libacl-2.2.51-9.fc19.x86_64 libattr-2.4.46-10.fc19.x86_64 libcap-2.22-6.fc19.x86_64 libldb-1.1.16-1.fc19.x86_64 libselinux-2.1.13-15.fc19.x86_64 ncurses-libs-5.9-11.20130511.fc19.x86_64 nspr-4.10.0-3.fc19.x86_64 nss-3.15.1-3.fc19.x86_64 nss-softokn-freebl-3.15.1-1.fc19.x86_64 nss-util-3.15.1-1.fc19.x86_64 openssl-libs-1.0.1e-4.fc19.x86_64 pam-1.1.6-12.fc19.x86_64 pcre-8.32-7.fc19.x86_64 zlib-1.2.7-10.fc19.x86_64
(gdb) list
557		/* this is quite a common operation, so we want it to be
558		   fast. We optimise for the ascii case, knowing that all our
559		   supported multi-byte character sets are ascii-compatible
560		   (ie. they match for the first 128 chars) */
562		while (*s && !(((unsigned char)s[0]) & 0x80)) {
563			*s = toupper_ascii_fast((unsigned char)*s);
564			s++;
565		}
(gdb) print s
$1 = 0x0
Comment 1 Milan Kerslager 2013-08-22 09:21:16 UTC
The workaround is to use command:

net rpc join -w YOURDOMAIN -Uyourdomainadminuser
Comment 2 Milan Kerslager 2013-08-22 10:25:15 UTC
(In reply to comment #1)
> The workaround is to use command:
> net rpc join -w YOURDOMAIN -Uyourdomainadminuser

This alternative seems do not auto-create machine accoutn on the server so this works, but it is mostly unusable.
Comment 3 Milan Kerslager 2013-08-22 11:01:26 UTC
(In reply to comment #1)
> The workaround is to use command:
> net rpc join -w YOURDOMAIN -Uyourdomainadminuser

The command "net rpc" join the computer into the domain but machine account is not auto-created (there is an error message in the log). So this is not workaround.

I tryed Windows XP machine to join the domain and my Samba server (the same like above) created the account and I was able to login to the domain. So the trust account was properly set.
Comment 4 Milan Kerslager 2013-08-22 11:02:21 UTC
The command "net ads join" segfaults on both 32 and 64bit Fedora 19 machines.
Comment 5 Andreas Schneider 2013-09-10 09:53:59 UTC

*** This bug has been marked as a duplicate of bug 10073 ***