Bug 10073 - net ads join - segmentation fault in create_local_private_krb5_conf_for_domain
net ads join - segmentation fault in create_local_private_krb5_conf_for_domain
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Client Tools
3.6.16
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 10102 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 14:44 UTC by Andreas Schneider
Modified: 2013-09-11 20:58 UTC (History)
2 users (show)

See Also:


Attachments
v3-6-test and v4-x-test patch (2.23 KB, patch)
2013-08-09 07:39 UTC, Andreas Schneider
asn: review? (gd)
ab: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2013-08-08 14:44:07 UTC
# gdb `which net` ./core.3541
...
Core was generated by `net -d10 ads join -U administrator%root'.
Program terminated with signal 11, Segmentation fault.
#0  0x00002b6b3fbd2e4d in strupper_m ()
(gdb) bt
#0  0x00002b6b3fbd2e4d in strupper_m ()
#1  0x00002b6b3fba7203 in create_local_private_krb5_conf_for_domain ()
#2  0x00002b6b3fdfd969 in ?? ()
#3  0x00002b6b3fdff37b in libnet_Join ()
#4  0x00002b6b3f9a43b8 in net_ads_join ()
#5  0x00002b6b3f9a2a00 in net_ads ()
#6  0x00002b6b3f9a1a72 in main ()

If no realm is specified we segfault. We should gracefully fail and print and error.
Comment 1 Andreas Schneider 2013-08-09 07:39:11 UTC
Created attachment 9117 [details]
v3-6-test and v4-x-test patch
Comment 2 Alexander Bokovoy 2013-08-09 10:15:13 UTC
Comment on attachment 9117 [details]
v3-6-test and v4-x-test patch

Looks good to me.
Comment 3 Andreas Schneider 2013-08-12 08:32:30 UTC
Karolin, could you please add the patch to 3.6, 4.0 and 4.1? Thanks!
Comment 4 Karolin Seeger 2013-08-13 08:17:19 UTC
(In reply to comment #3)
> Karolin, could you please add the patch to 3.6, 4.0 and 4.1? Thanks!

Pushed to autobuild-v4-1-test and autobuild-v4-0-test.
Needs to be pushed to v3-6-test after the release of Samba 3.6.18.
Comment 5 Karolin Seeger 2013-08-14 08:57:09 UTC
Pushed to v4-1-test, v4-0-test and v3-6-test.
Closing out bug report.

Thanks!
Comment 6 Andreas Schneider 2013-09-10 09:53:59 UTC
*** Bug 10102 has been marked as a duplicate of this bug. ***
Comment 7 Milan Kerslager 2013-09-11 20:58:25 UTC
This bug showed me, when I was trying to join classical domain with command for joining the AD (which could be printed along).