Bug 10030 - ::1 added to nameserver on join
::1 added to nameserver on join
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
4.0.6
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9328 (view as bug list)
Depends on:
Blocks: 9306
  Show dependency treegraph
 
Reported: 2013-07-17 16:57 UTC by Björn Jacke
Modified: 2013-09-02 10:32 UTC (History)
3 users (show)

See Also:


Attachments
proposed patch (1.82 KB, patch)
2013-07-17 17:02 UTC, Björn Jacke
no flags Details
patch for 4.1 (4.94 KB, patch)
2013-08-31 19:35 UTC, Björn Jacke
bjacke: review+
metze: review+
Details
patch for 4.0 (4.94 KB, patch)
2013-08-31 19:40 UTC, Björn Jacke
bjacke: review+
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2013-07-17 16:57:06 UTC
with "lo" listed in "interfaces" samba was registering ::1 at the DNS server. This is not a good idea o obviously.
Comment 1 Björn Jacke 2013-07-17 17:02:12 UTC
Created attachment 9056 [details]
proposed patch

this patch fixed this for me. I don't know what the !!all_interfaces contruct was intended to do actually, this here looks good to me. Comments ?
Comment 2 Björn Jacke 2013-07-17 19:05:14 UTC
*** Bug 9328 has been marked as a duplicate of this bug. ***
Comment 3 Stefan Metzmacher 2013-08-29 17:45:30 UTC
We should try to fix this for 4.1.0
Comment 4 Stefan Metzmacher 2013-08-29 17:46:07 UTC
I'm working with Björn on a fix
Comment 5 Björn Jacke 2013-08-31 19:35:18 UTC
Created attachment 9180 [details]
patch for 4.1

fixed in master with 3430448fc01ce3fbe0606a2c239d3c98a5b78361~3

the patch from metze, for 4.1. Karo, please pick to 4.1, eliminated another blocker :-)
Comment 6 Björn Jacke 2013-08-31 19:40:37 UTC
Created attachment 9181 [details]
patch for 4.0

Karo, please also pick this to 4.0
Comment 7 Karolin Seeger 2013-09-02 07:47:41 UTC
Pushed to autobuild-v4-1-test and autobuild-v4-0-test.
Comment 8 Karolin Seeger 2013-09-02 10:32:08 UTC
Pushed to v4-1-test and v4-0-test.
Closing out bug report.

Thanks!