Bug 9958 - problem with MX record
problem with MX record
Status: RESOLVED DUPLICATE of bug 9485
Product: Samba 4.0
Classification: Unclassified
Component: DNS server
4.0.5
x64 Linux
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 09:49 UTC by Caiman
Modified: 2013-06-18 23:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caiman 2013-06-18 09:49:19 UTC
I do have problem with MX record



1) samba-tool dns add  dcmsc.test.inc test.inc test.inc MX 'mail.test.inc 10'


2) samba-tool dns query  dcmsc.test.inc test.inc test.inc MX



3) [root@dcmsc caiman]# samba-tool dns query  dcmsc.test.inc test.inc test.inc MX
Password for [administrator@test.INC]:
  Name=, Records=1, Children=0
    MX: mail.test.inc. (5) (flags=600000f0, serial=10, ttl=0)
  Name=_msdcs, Records=0, Children=0
  Name=_sites, Records=0, Children=1
  Name=_tcp, Records=0, Children=4
  Name=_udp, Records=0, Children=2
  Name=dcmsc, Records=0, Children=0
  Name=DCSPB, Records=0, Children=0
  Name=DomainDnsZones, Records=0, Children=2
  Name=ForestDnsZones, Records=0, Children=2
  Name=mail, Records=0, Children=0
  Name=XP-77-86, Records=0, Children=0




4)#Dig from same box( From another box same result )
[root@dcmsc caiman]# dig @127.0.0.1 mx test.inc

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 <<>> @127.0.0.1 mx test.inc
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOTIMP, id: 62639
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;test.inc.                   IN      MX

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat May  4 21:12:29 2013
;; MSG SIZE  rcvd: 29

#From samba4 box logs
[2013/05/04 15:46:43,  0] ../source4/dns_server/dns_query.c:103(create_response_rr)
  Got unhandled type 15 query.
Comment 1 Kai Blin 2013-06-18 10:34:41 UTC
Will be fixed in the next bugfix release, but it's not fixed in 4.0.5 (or 4.0.6) yet. See bug #9485 for a patch if you want to fix the problem before the next bugfix release.

*** This bug has been marked as a duplicate of bug 9485 ***
Comment 2 Caiman 2013-06-18 23:19:57 UTC
Hello Kay Blin
Thanks for quick answer.
After patch , it looks better , however , SOA record possibly broken.

It said :  "AUTHORITY: 0" 


######## from samba box###############
 dig test.inc mx

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 <<>> test.inc mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1576
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;test.inc.                   IN      MX

;; ANSWER SECTION:
test.inc.            0       IN      MX      10 mail.test.inc.


;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jun 19 03:16:41 2013
;; MSG SIZE  rcvd: 66

#######################

Thanks,
Konstantin Pobudzey.


----- Original Message -----
From: samba-bugs@samba.org
To: 5836000@gmail.com
Sent: Tuesday, June 18, 2013 6:34:41 AM
Subject: [Bug 9958] problem with MX record

https://bugzilla.samba.org/show_bug.cgi?id=9958

Kai Blin <kai@samba.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |DUPLICATE

--- Comment #1 from Kai Blin <kai@samba.org> 2013-06-18 10:34:41 UTC ---
Will be fixed in the next bugfix release, but it's not fixed in 4.0.5 (or
4.0.6) yet. See bug #9485 for a patch if you want to fix the problem before the
next bugfix release.

*** This bug has been marked as a duplicate of bug 9485 ***