Bug 9940 - Does not offer version 3 printer drivers to Windows 8 clients
Does not offer version 3 printer drivers to Windows 8 clients
Status: RESOLVED DUPLICATE of bug 9474
Product: Samba 3.6
Classification: Unclassified
Component: Printing
3.6.6
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 05:48 UTC by Christian Perrier
Modified: 2013-06-11 08:12 UTC (History)
1 user (show)

See Also:


Attachments
Patch for 3.6.6 (2.29 KB, patch)
2013-06-08 05:48 UTC, Christian Perrier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Perrier 2013-06-08 05:48:05 UTC
Created attachment 8952 [details]
Patch for 3.6.6

This bug was reported in Debian. The bug submitter mentions that the bug occurs with both 3.5.6 (which we have in Debian squeeze) and 3.6.6 (which we have in Debian wheezy) :

Bug submitter's text:

When a Windows 8 client requests a version 4 printer driver, and one is not
available, Samba then tries to find a version 2 driver and skips out V3.
When only V3 drivers are installed, this results in no useful offer to the
client.

The result is that Windows 8 clients are unable to connect using the Point
and Print mechanism.

Patches for Wheezy and Squeeze to follow. I loop down the available versions
to find one to offer, even if it's not the version the client requested. This
has the advantage of not needing another change if the requested version
increases again in the future. More work would be needed to actually support
version 4 drivers properly however.

Our client confirmed that this solved the problem for them.
Comment 1 Andreas Schneider 2013-06-10 15:36:42 UTC
This is already fixed since samba-3.6.13.

*** This bug has been marked as a duplicate of bug 9474 ***