Bug 9923 - MRxSmb - Delayed Write Failed since upgrade from 3.0.28 to 3.6.3
MRxSmb - Delayed Write Failed since upgrade from 3.0.28 to 3.6.3
Product: Samba 3.6
Classification: Unclassified
Component: File services
x64 All
: P5 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2013-06-03 10:03 UTC by Manfred
Modified: 2013-06-05 11:04 UTC (History)
0 users

See Also:

Logfile - debuglevel 3 (13.51 KB, application/octet-stream)
2013-06-03 10:03 UTC, Manfred
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred 2013-06-03 10:03:05 UTC
Created attachment 8938 [details]
Logfile - debuglevel 3

I upgraded Ubuntu 8.04 to 12.04 (via 10.04) and also the included samba version changed from 3.0.28 to 3.6.3.

Since then we have got the problem that from time to time windows xp computers get the error message "Delay Write Failed" and some programs crash (e.g. firefox - profiles stored at network drive).

We already added "keepalive" and "deadtime" to our smb.conf and tried different values, but the problem still resists.

This is our smb.conf file:

     workgroup = NT
     server string = filer01

     security = user
     encrypt passwords = true
     server signing = disabled

     lanman auth = yes

     unix extensions = no
     socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

     keepalive = 45000
     deadtime = 15
     smb ports = 445

     local master = Yes
     interfaces = bond0
     wins support = yes
     domain logons = Yes
     domain master = Yes
     preferred master = yes
     time server = yes

     unix charset = UTF8

     load printers = yes
     printing = cups
     printcap name = cups

     disable spoolss = yes

     username map = /etc/samba/smbusers
     logon script = login.cmd
     logon path = 
     logon home = 
     logon drive = L:

     log file = /var/log/samba/log.%m
     max log size = 5000

     os level = 33

     passwd program = /usr/sbin/smbldap-passwd %u
     passwd chat = *password* %n\n *password* %n\n *changed*

     add machine script = /usr/sbin/smbldap-useradd -w "%u"
     add user script = /usr/sbin/smbldap-useradd -m "%u"
     ldap delete dn = Yes
     add group script = /usr/sbin/smbldap-groupadd -p "%g"
     delete group script = /usr/sbin/smbldap-groupdel "%g"
     add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
     delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
     set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"

     passdb backend = ldapsam:ldap://
     ldap admin dn = "cn=admin,dc=thisnet,dc=here"
     ldap ssl = off
     ldap group suffix = ou=Groups
     ldap user suffix = ou=Users
     ldap machine suffix = ou=Computers
     ldap suffix = dc=thisnet,dc=here
     ldap delete dn = no

     use sendfile = Yes

     debuglevel = 3
     debug class = yes

   comment = Home Directories
   valid users = %S
   browseable = No
   read only = No
   inherit acls = Yes
   create mode = 0700

  comment = Programme
  path = /srv/samba/programm
  read only = no
  browseable = yes
  public = no
  create mode = 770
  directory mode = 770
  force group = alle

And attached the logfile from a windows xp computer at the time the "Delayed Write Failed" failure happend.

Any tips, suggestions?
Before the update we had no problems!
No hardware changes.

Comment 1 Björn Jacke 2013-06-05 11:04:32 UTC
3.6.3 is not a version you should use, it is old, 3.6 has seen *many* fixes since. Please update at least to the latest 3.6 or the lastest 4.0 version. You can find ready built packages for ubuntu also. If the error still happens, please attach a level 10 log of the client's smbd process, see https://wiki.samba.org/index.php/Client_specific_Log . I'll close this as worksforme. Please reopen if you tested with latest versions and still get the error.