Bug 99 - can't join XP (w or w/o SP)
can't join XP (w or w/o SP)
Status: RESOLVED DUPLICATE of bug 85
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0preX
Other Windows XP
: P2 regression
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-20 09:46 UTC by Ignacio Coupeau
Modified: 2005-02-07 07:57 UTC (History)
0 users

See Also:


Attachments
Only register lsa_query_info2 if we're an ADS PDC (1.00 KB, patch)
2003-05-22 07:41 UTC, Anthony Liguori
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ignacio Coupeau 2003-05-20 09:46:47 UTC
compiled linux 2.4. ldapsam and ldapsam_compat.

I tried almost all possibilities (spnego's, policies, sign* registry entries,
SP, no SP) to joins an XP to the Samba a24 domain. The XP says that joins to the
domain (root account and so), but after reboot say that the domain is not
available, but is available for any joined NT ws and for serve shares to the XP
that can't joins.

Symtoms:
- the he domain list in the logon window shows the correct domain name for
example "cti-smb-3"
- is not allowed to log on with any (root or less privileged) domain user
account: the domain is not available at this moment (the SID and so are well).
- but after login as a local user, I can mount a share from the PDC as the user
that can't logs
- in the PC|properties| name shows:
    machine name: cti-xp1 (OK)
    domain: cti.unav.es (BAD: is the DNS domain name, and sounds me like an AD
realm) 

Also I tried to compile Samba without AD but the ldapsam compilation crashes
without AD.

As I use a real wins, I can log heavier or the log may be a *real* log ;_)
[2003/05/20 17:09:59, 1] nmbd/nmbd_processlogon.c:process_logon_packet(96)
  process_logon_packet: Logon from 159.237.118.248: code = 0x12
[2003/05/20 17:09:59, 1] nmbd/nmbd_processlogon.c:process_logon_packet(96)
  process_logon_packet: Logon from 159.237.118.248: code = 0x12
[2003/05/20 17:10:00, 1] nmbd/nmbd_processlogon.c:process_logon_packet(96)
  process_logon_packet: Logon from 159.237.118.248: code = 0x12
[2003/05/20 17:10:07, 1] nmbd/nmbd_processlogon.c:process_logon_packet(96)
  process_logon_packet: Logon from 159.237.118.248: code = 0x7
Comment 1 Gerald (Jerry) Carter 2003-05-21 09:59:09 UTC
reproduced locally here....
Comment 2 Gerald (Jerry) Carter 2003-05-21 10:30:58 UTC
Bug 85 is probably related
Comment 3 Anthony Liguori 2003-05-22 07:41:10 UTC
Created attachment 12 [details]
Only register lsa_query_info2 if we're an ADS PDC

This patch forces the LSA rpc pipe only to register lsa_query_info2 if we're an
ADS PDC.  We'll probably encounter more of this in the future and this is
probably where we should be handling these types of things.
Comment 4 Gerald (Jerry) Carter 2003-05-22 07:50:53 UTC
patch looks good btw...

*** This bug has been marked as a duplicate of 85 ***
Comment 5 Gerald (Jerry) Carter 2003-05-22 07:51:17 UTC
removed dependency
Comment 6 Gerald (Jerry) Carter 2005-02-07 07:57:10 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.