Bug 989 - Single Quotes in machine's comment field causes machine to be ignored by lanman.
Summary: Single Quotes in machine's comment field causes machine to be ignored by lanman.
Status: RESOLVED DUPLICATE of bug 1221
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control (show other bugs)
Version: 3.0.1
Hardware: All Linux
: P4 minor
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-19 07:13 UTC by Glenn Atter
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glenn Atter 2004-01-19 07:13:26 UTC
We have a number of Win2k & WinXP machines in a domain using samba 3.0.2 as the
PDC. A number of machines were missing from the list of machines genereated by
smbclient (on the server) and net view (on the windows machines). After a little
bit of work it was apparent that the missing machines had comments that included
a single quote like "joe's computer". When the single-quote is removed from the
comment the machine appears back on the list of available machines. 

It appears that lib/util_str.c:next_token returns incorrect information for the
comment and domain in smbd/lanman.c:get_server_info. As the domain does not
match the computer is not included in the list.
Comment 1 Gerald (Jerry) Carter 2004-04-22 20:14:33 UTC

*** This bug has been marked as a duplicate of 1221 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:30:23 UTC
database cleanup