Bug 9859 - permission denied when trying to create/modify files/dirs after upgrade to 3.6.13
permission denied when trying to create/modify files/dirs after upgrade to 3....
Status: RESOLVED DUPLICATE of bug 9746
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.13
All All
: P5 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-06 06:29 UTC by Arkadiusz Miskiewicz
Modified: 2013-05-09 18:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkadiusz Miskiewicz 2013-05-06 06:29:16 UTC
I'm using samba 3.6.12 on server side and mounting it from linux client using options:
cifs    passwd="",uid=1000,gid=1000,file_mode=0644,sec=ntlmv2,noauto

After server upgrade to 3.6.13 (same with 3.6.14) I'm no longer able to delete files on such mounted share -> "permission denied". Downgrade to 3.6.12 and things are back to normal.

touch x:
open("x", O_WRONLY|O_CREAT|O_NOCTTY|O_NONBLOCK, 0666) = -1 EACCES (Permission denied)

/proc/mounts looks like this:

//x.x.0.249/something /mnt/floppy cifs rw,relatime,vers=1.0,sec=ntlmv2,cache=strict,unc=\134\134x.x.0.249\134something,username=root,domain=WORKGROUP,uid=1000,forceuid,gid=1000,forcegid,addr=x.x.0.249,unix,posixpaths,serverino,acl,rsize=1048576,wsize=65536,actimeo=1 0 0

mkdir x incorrectly failing on 3.6.14:
[2013/05/06 08:25:47.606261,  3] smbd/process.c:1609(process_smb)
  Transaction 13 of length 82 (0 toread)
[2013/05/06 08:25:47.606593,  3] smbd/process.c:1414(switch_message)
  switch message SMBtrans2 (pid 24588) conn 0x7f09c66f1110
[2013/05/06 08:25:47.606804,  3] smbd/trans2.c:5184(call_trans2qfilepathinfo)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 512
[2013/05/06 08:25:47.606976,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:25:47.607312,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
[2013/05/06 08:25:47.607660,  3] smbd/trans2.c:5292(call_trans2qfilepathinfo)
  call_trans2qfilepathinfo: SMB_VFS_LSTAT of x failed (No such file or directory)
[2013/05/06 08:25:47.607920,  3] smbd/error.c:81(error_packet_set)
  error packet at smbd/trans2.c(5294) cmd=50 (SMBtrans2) NT_STATUS_OBJECT_NAME_NOT_FOUND
[2013/05/06 08:25:47.608730,  3] smbd/process.c:1609(process_smb)
  Transaction 14 of length 102 (0 toread)
[2013/05/06 08:25:47.609023,  3] smbd/process.c:1414(switch_message)
  switch message SMBtrans2 (pid 24588) conn 0x7f09c66f1110
[2013/05/06 08:25:47.609225,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:25:47.609396,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
[2013/05/06 08:25:47.609531,  3] smbd/trans2.c:8124(call_trans2setfilepathinfo)
  call_trans2setfilepathinfo(6) x (fnum -1) info_level=521 totdata=18
[2013/05/06 08:25:47.609669,  3] smbd/trans2.c:7701(smbd_do_setfilepathinfo)
  smbd_do_setfilepathinfo: x (fnum -1) info_level=521 totdata=18
[2013/05/06 08:25:47.609815,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:25:47.609990,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
[2013/05/06 08:25:47.610137,  2] smbd/open.c:2660(open_directory)
  open_directory: unable to create x. Error was NT_STATUS_ACCESS_DENIED
[2013/05/06 08:25:47.610287,  0] smbd/trans2.c:1296(unix_filetype)
  unix_filetype: unknown filetype 0
[2013/05/06 08:25:47.610680,  0] smbd/trans2.c:1296(unix_filetype)
  unix_filetype: unknown filetype 0
[2013/05/06 08:25:47.611065,  0] smbd/trans2.c:1296(unix_filetype)
  unix_filetype: unknown filetype 0
[2013/05/06 08:25:47.611379,  0] smbd/trans2.c:1296(unix_filetype)
  unix_filetype: unknown filetype 0
[2013/05/06 08:25:47.611674,  3] smbd/error.c:81(error_packet_set)
  error packet at smbd/error.c(161) cmd=50 (SMBtrans2) NT_STATUS_ACCESS_DENIED
[2013/05/06 08:25:52.020626,  3] printing/printing.c:1689(printer_housekeeping_fn)
  Printcap cache time expired.
[2013/05/06 08:25:52.021028,  3] printing/pcap.c:138(pcap_cache_reload)
  reloading printcap cache


the same mkdir x correctly done on 3.6.12:
[2013/05/06 08:27:39.833846,  3] smbd/process.c:1662(process_smb)
  Transaction 10 of length 82 (0 toread)
[2013/05/06 08:27:39.834237,  3] smbd/process.c:1467(switch_message)
  switch message SMBtrans2 (pid 24662) conn 0x7faf63b6bd60
[2013/05/06 08:27:39.834483,  3] smbd/trans2.c:5132(call_trans2qfilepathinfo)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 512
[2013/05/06 08:27:39.834682,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:27:39.834863,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
[2013/05/06 08:27:39.835039,  3] smbd/trans2.c:5240(call_trans2qfilepathinfo)
  call_trans2qfilepathinfo: SMB_VFS_LSTAT of x failed (No such file or directory)
[2013/05/06 08:27:39.835190,  3] smbd/error.c:81(error_packet_set)
  error packet at smbd/trans2.c(5242) cmd=50 (SMBtrans2) NT_STATUS_OBJECT_NAME_NOT_FOUND
[2013/05/06 08:27:39.835864,  3] smbd/process.c:1662(process_smb)
  Transaction 11 of length 102 (0 toread)
[2013/05/06 08:27:39.836158,  3] smbd/process.c:1467(switch_message)
  switch message SMBtrans2 (pid 24662) conn 0x7faf63b6bd60
[2013/05/06 08:27:39.836345,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:27:39.836528,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
[2013/05/06 08:27:39.836660,  3] smbd/trans2.c:8065(call_trans2setfilepathinfo)
  call_trans2setfilepathinfo(6) x (fnum -1) info_level=521 totdata=18
[2013/05/06 08:27:39.836796,  3] smbd/trans2.c:7642(smbd_do_setfilepathinfo)
  smbd_do_setfilepathinfo: x (fnum -1) info_level=521 totdata=18
[2013/05/06 08:27:39.837236,  3] smbd/vfs.c:905(check_reduced_name)
  check_reduced_name [x] [/mnt/storage-sda-noraid/public]
[2013/05/06 08:27:39.837606,  3] smbd/vfs.c:1039(check_reduced_name)
  check_reduced_name: x reduced to /something/x
Comment 1 Arkadiusz Miskiewicz 2013-05-09 18:06:22 UTC

*** This bug has been marked as a duplicate of bug 9746 ***