Bug 9842 - winbind/samba crash during ls -lha / getfacl
winbind/samba crash during ls -lha / getfacl
Status: RESOLVED DUPLICATE of bug 9820
Product: Samba 4.0
Classification: Unclassified
Component: Winbind
All All
: P5 major
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on: 9820
  Show dependency treegraph
Reported: 2013-04-30 17:17 UTC by Nick Semenkovich
Modified: 2013-07-13 07:41 UTC (History)
0 users

See Also:

gdb bt full (51.18 KB, text/plain)
2013-04-30 17:17 UTC, Nick Semenkovich
no flags Details
bt full, now built to git head, 5f82641 (51.30 KB, text/plain)
2013-04-30 21:26 UTC, Nick Semenkovich
no flags Details
gdb full PID 10735 (22.25 KB, text/plain)
2013-07-02 20:31 UTC, Nick Semenkovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Semenkovich 2013-04-30 17:17:29 UTC
Created attachment 8841 [details]
gdb bt full

Intermittently, samba w/ winbind integration crashes during an ls -lha / getfacl of a file.

Before the crash, owners are listed correctly (e.g. as their samba "DOMAIN\user"). After the crash, many calls hang, and ls -lha takes 10-15+ seconds.

This is compiled from the recent git:

commit 08d7caedf0f549d6ca61dc939d94fc267d7d54d4
Author: Andreas Schneider <asn@samba.org>
Date:   Fri Oct 26 19:52:08 2012 +0200

    regedit: Use color only when available.

    Signed-off-by: Andreas Schneider <asn@samba.org>
    Reviewed-by: Michael Adam <obnox@samba.org>

    Autobuild-User(master): Michael Adam <obnox@samba.org>
    Autobuild-Date(master): Mon Apr 29 15:02:19 CEST 2013 on sn-devel-104

Attached is a gdb backtrace.
Comment 1 Nick Semenkovich 2013-04-30 17:21:06 UTC
Note that this is just before the patch for bug 9832, though I don't see the same "Bad talloc" signature in the backtrace.
Comment 2 Nick Semenkovich 2013-04-30 21:25:34 UTC
This happens pretty frequently with "ls -lha" when looking at files owned by AD DC users. This seems to happen 100% of the time with "getfacl" on AD DC-owned files, though I'm trying to make a cleaner test case.

I'll attach a second bt full from a repeat crash, in case it's helpful.
Comment 3 Nick Semenkovich 2013-04-30 21:26:35 UTC
Created attachment 8843 [details]
bt full, now built to git head, 5f82641
Comment 4 Nick Semenkovich 2013-07-02 20:20:09 UTC
Have some logs of this crash today at debug level 8.

Still seeing this as of the recent commit:

commit af41eb6bd4889a7cd0c7a0bd1553e3534f8f06ad
Author: Aurélien Aptel <aurelien.aptel@gmail.com>
Date:   Fri Jun 28 17:34:26 2013 +0200

    docs-xml/manpages/smbclient.1.xml: fix case of -T flag in example.
    Signed-off-by: Aurélien Aptel <aurelien.aptel@gmail.com>
    Reviewed-by: David Disseldorp <ddiss@samba.org>
    Autobuild-User(master): David Disseldorp <ddiss@samba.org>
    Autobuild-Date(master): Fri Jun 28 17:45:31 CEST 2013 on sn-devel-1
Comment 5 Nick Semenkovich 2013-07-02 20:31:10 UTC
Created attachment 9015 [details]
gdb full PID 10735
Comment 6 Nick Semenkovich 2013-07-02 20:35:31 UTC
Hm, I think this crash is related to bug #9853

I noticed "krb5_cc_store_cred" in this trace, but from the logs I also see:

[2013/07/02 15:04:52.210352,  0] ../source3/smbd/open.c:1527(defer_open_done)
  PANIC: assert failed at ../source3/smbd/open.c(1527): ret
[2013/07/02 15:04:52.210487,  0] ../source3/lib/util.c:810(smb_panic_s3)
  PANIC (pid 18799): assert failed: ret
Comment 7 Nick Semenkovich 2013-07-13 01:07:07 UTC
Appears fixed as of latest version ~ commit 596b51c666e
Comment 8 Andrew Bartlett 2013-07-13 07:41:19 UTC
While this was filed first, mark as duplicate of the bug with the patches in it for 4.0 and 4.1

*** This bug has been marked as a duplicate of bug 9820 ***